summaryrefslogtreecommitdiff
path: root/gnuradio-core/src/Makefile.am
diff options
context:
space:
mode:
authorjcorgan2009-05-27 01:54:41 +0000
committerjcorgan2009-05-27 01:54:41 +0000
commit40b8a57d69b4b85f207fb0408347c210e23202cc (patch)
tree8d1e3bbc9159bdd0de98bb897432abd81563dbca /gnuradio-core/src/Makefile.am
parente3cd8f7d59aad0ffd51c417b2623ab02588fdb08 (diff)
downloadgnuradio-40b8a57d69b4b85f207fb0408347c210e23202cc.tar.gz
gnuradio-40b8a57d69b4b85f207fb0408347c210e23202cc.tar.bz2
gnuradio-40b8a57d69b4b85f207fb0408347c210e23202cc.zip
Merged r11123:11148 from jcorgan/np into trunk.
Adds --enable-python option to configure (defaults to yes). Using --disable-python or --enable-python=no will cause only C++ API targets to be created and installed. Several new shared libraries are now created. Where in the past, the C++ objects of the actual gnuradio blocks that were in a component were hidden inside their corresponding Python extension modules, these are now split out into a libgnuradio-foo.so library, and the _foo.so Python module is linked to that. This has been the way several top- level components have operated for some time, such as gr-audio-alsa and gr-usrp and gr-usrp2. This changeset applies that pattern to all components. C++ API users can use pkg-config to discover the cflags and libs parameters needed to include and link against these libraries. These components have not been tested: gr-comedi gr-audio-osx gr-audio-windows Passes distcheck. git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@11150 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gnuradio-core/src/Makefile.am')
-rw-r--r--gnuradio-core/src/Makefile.am7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnuradio-core/src/Makefile.am b/gnuradio-core/src/Makefile.am
index 7b325974a..eb979fe58 100644
--- a/gnuradio-core/src/Makefile.am
+++ b/gnuradio-core/src/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2001,2004 Free Software Foundation, Inc.
+# Copyright 2001,2004,2009 Free Software Foundation, Inc.
#
# This file is part of GNU Radio
#
@@ -21,6 +21,9 @@
include $(top_srcdir)/Makefile.common
-SUBDIRS = gen_interpolator_taps lib tests python
+SUBDIRS = gen_interpolator_taps lib tests
+if PYTHON
+SUBDIRS += python
+endif
DIST_SUBDIRS = gen_interpolator_taps lib tests python utils