summaryrefslogtreecommitdiff
path: root/gnuradio-core/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum2011-07-30 10:31:02 -0700
committerJosh Blum2011-08-02 12:45:54 -0700
commit7125a92e1bf7483656af6ef8dcc0be7626a30a82 (patch)
treef4f23819757e610462818caddb7a92077e426033 /gnuradio-core/CMakeLists.txt
parentfbe4a14d8fb6d6696bd0ac8a4921ba1269601d78 (diff)
downloadgnuradio-7125a92e1bf7483656af6ef8dcc0be7626a30a82.tar.gz
gnuradio-7125a92e1bf7483656af6ef8dcc0be7626a30a82.tar.bz2
gnuradio-7125a92e1bf7483656af6ef8dcc0be7626a30a82.zip
core: dont set boost vars for gnuradio-core.pc
If this is useful, it should be in gruel.pc; but gruel.pc has no private libs or boost dirs. Also, the substitution of absolute boost library paths is bad for cross builds (even native ones)
Diffstat (limited to 'gnuradio-core/CMakeLists.txt')
-rw-r--r--gnuradio-core/CMakeLists.txt13
1 files changed, 0 insertions, 13 deletions
diff --git a/gnuradio-core/CMakeLists.txt b/gnuradio-core/CMakeLists.txt
index 3782ae0ed..1c133efb9 100644
--- a/gnuradio-core/CMakeLists.txt
+++ b/gnuradio-core/CMakeLists.txt
@@ -131,19 +131,6 @@ ENDIF(ENABLE_PYTHON)
# Create Pkg Config File
########################################################################
FILE(TO_NATIVE_PATH "\${prefix}/${GR_INCLUDE_DIR}/gnuradio" includedir) #different from other gr modules
-FILE(TO_NATIVE_PATH "${CMAKE_INSTALL_PREFIX}/${GR_DATA_DIR}/guile/site" guile_load_path) #screw this...
-
-FOREACH(boost_include ${Boost_INCLUDE_DIRS})
- SET(BOOST_CXXFLAGS "-I${boost_include} ${BOOST_CXXFLAGS}")
-ENDFOREACH(boost_include)
-
-FOREACH(boost_libdir ${Boost_LIBRARY_DIRS})
- SET(BOOST_LDFLAGS "-L${boost_libdir} ${BOOST_LDFLAGS}")
-ENDFOREACH(boost_libdir)
-
-FOREACH(boost_ldflag ${Boost_LIBRARIES})
- SET(BOOST_LDFLAGS "${boost_ldflag} ${BOOST_LDFLAGS}")
-ENDFOREACH(boost_ldflag)
CONFIGURE_FILE(
${CMAKE_CURRENT_SOURCE_DIR}/gnuradio-core.pc.in