summaryrefslogtreecommitdiff
path: root/gcell/src/lib/spu/Makefile.am
diff options
context:
space:
mode:
authoreb2008-04-16 03:48:33 +0000
committereb2008-04-16 03:48:33 +0000
commit8f2a5f3837da61a4d49251ee65f91f0d2e8e48de (patch)
tree750df8032c31b412a413ce749ec30d9363ac56f5 /gcell/src/lib/spu/Makefile.am
parent6d234892030754c0cd058ad85d2c3759b0538c90 (diff)
downloadgnuradio-8f2a5f3837da61a4d49251ee65f91f0d2e8e48de.tar.gz
gnuradio-8f2a5f3837da61a4d49251ee65f91f0d2e8e48de.tar.bz2
gnuradio-8f2a5f3837da61a4d49251ee65f91f0d2e8e48de.zip
Merged gcell-wip -r8159:8202 into trunk. This includes the following
changes: * gc_make_job_manager now returns a boost::shared_ptr * opts.program_handle is now a boost::shared_ptr * two new functions for getting a program handle * look_proc and alloc_job_desc now throw on error * static methods for setting and getting a single job manager * new exception hierarchy * mv gcell/src/lib/procs gcell/src/lib/wrapper * added libfft. Currently inverse xform is broken * gcell-embedspu-libtool creates libtool complaint .ko's from SPE executables git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@8209 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gcell/src/lib/spu/Makefile.am')
-rw-r--r--gcell/src/lib/spu/Makefile.am41
1 files changed, 26 insertions, 15 deletions
diff --git a/gcell/src/lib/spu/Makefile.am b/gcell/src/lib/spu/Makefile.am
index fac057cd5..3c96d8f30 100644
--- a/gcell/src/lib/spu/Makefile.am
+++ b/gcell/src/lib/spu/Makefile.am
@@ -57,23 +57,28 @@ runtime_spu_noinst_headers = \
general_srcdir = $(srcdir)/../general/spu
-general_spu_sources =
+general_spu_sources = \
+ $(general_srcdir)/fft_1d_r2.c
-general_spu_headers =
+general_spu_headers = \
+ $(general_srcdir)/libfft.h
-general_spu_noinst_headers =
+general_spu_noinst_headers = \
+ $(general_srcdir)/fft_1d.h \
+ $(general_srcdir)/fft_1d_r2.h
# ----------------------------------------------------------------
-# files in the lib/procs/spu directory
+# files in the lib/wrapper/spu directory
-procs_srcdir = $(srcdir)/../proc/spu
+wrapper_srcdir = $(srcdir)/../wrapper/spu
-procs_spu_sources =
+wrapper_spu_sources = \
+ $(wrapper_srcdir)/gcs_fft_1d_r2.c
-procs_spu_headers =
+wrapper_spu_headers =
-procs_spu_noinst_headers =
+wrapper_spu_noinst_headers =
# ----------------------------------------------------------------
# build the library from the files in the three directories
@@ -81,23 +86,29 @@ procs_spu_noinst_headers =
libgcell_spu_a_SOURCES = \
$(runtime_spu_sources) \
$(general_spu_sources) \
- $(procs_spu_sources)
+ $(wrapper_spu_sources)
gcellspuinclude_HEADERS = \
$(runtime_spu_headers) \
$(general_spu_headers) \
- $(procs_spu_headers)
+ $(wrapper_spu_headers)
noinst_HEADERS = \
$(runtime_spu_noinst_headers) \
$(general_spu_noinst_headers) \
- $(procs_spu_noinst_headers)
+ $(wrapper_spu_noinst_headers)
# ----------------------------------------------------------------
-# SPU executable containing QA code
+# SPU executables
noinst_PROGRAMS = \
- gcell_qa
+ gcell_all \
+ gcell_runtime_qa
-gcell_qa_SOURCES = $(runtime_srcdir)/gcell_qa.c
-gcell_qa_LDADD = libgcell_spu.a
+# all known gcell procs (at least until they get too big)
+gcell_all_SOURCES = $(wrapper_spu_sources)
+gcell_all_LDADD = libgcell_spu.a
+
+# just the QA code required for testing the runtime
+gcell_runtime_qa_SOURCES = $(runtime_srcdir)/gcell_runtime_qa.c
+gcell_runtime_qa_LDADD = libgcell_spu.a