summaryrefslogtreecommitdiff
path: root/gcell/src/apps/Makefile.am
diff options
context:
space:
mode:
authoreb2008-03-24 06:09:29 +0000
committereb2008-03-24 06:09:29 +0000
commit28361a1bfc8f155a7b1367a234c9256b7b69da38 (patch)
treed75e71d0e87a56a542f905256688475662eee075 /gcell/src/apps/Makefile.am
parenta3ee0a2d8557477c873fb0bb43a34455944f7f58 (diff)
downloadgnuradio-28361a1bfc8f155a7b1367a234c9256b7b69da38.tar.gz
gnuradio-28361a1bfc8f155a7b1367a234c9256b7b69da38.tar.bz2
gnuradio-28361a1bfc8f155a7b1367a234c9256b7b69da38.zip
Merged gcell, the Cell SPE scheduler and RPC mechanism into the trunk.
(eb/trunk-with-gcell r8037:8085). Expect additional tweaks, but currently works and passes distcheck. git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@8086 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'gcell/src/apps/Makefile.am')
-rw-r--r--gcell/src/apps/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/gcell/src/apps/Makefile.am b/gcell/src/apps/Makefile.am
new file mode 100644
index 000000000..e8cbf3cfc
--- /dev/null
+++ b/gcell/src/apps/Makefile.am
@@ -0,0 +1,47 @@
+#
+# Copyright 2007,2008 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+SUBDIRS = spu .
+
+AM_CPPFLAGS = $(DEFINES) $(OMNITHREAD_INCLUDES) $(MBLOCK_INCLUDES) \
+ $(GCELL_INCLUDES) $(CPPUNIT_INCLUDES) $(WITH_INCLUDES)
+
+
+GCELL_QA_LA = $(top_builddir)/gcell/src/lib/libgcell-qa.la
+
+TESTS = test_all
+
+
+bin_PROGRAMS = \
+ test_all \
+ benchmark_dma \
+ benchmark_nop
+
+
+test_all_SOURCES = test_all.cc
+test_all_LDADD = $(GCELL_QA_LA) $(GCELL_LA)
+
+benchmark_dma_SOURCES = benchmark_dma.cc
+benchmark_dma_LDADD = spu/benchmark_procs $(GCELL_LA) $(MBLOCK_LA)
+
+benchmark_nop_SOURCES = benchmark_nop.cc
+benchmark_nop_LDADD = spu/benchmark_procs $(GCELL_LA) $(MBLOCK_LA)