summaryrefslogtreecommitdiff
path: root/ezdop/src/host/hunter/configure.ac
diff options
context:
space:
mode:
authorjcorgan2006-08-12 23:25:38 +0000
committerjcorgan2006-08-12 23:25:38 +0000
commit676acd5cc47828bc92c2fad1e474a39aacbd2ba4 (patch)
tree55a35ee87ae50ea6acc113b20ec28045ca0c9b5f /ezdop/src/host/hunter/configure.ac
parent0b9b3564fd50c630fbbce7a06fda134ae5468828 (diff)
downloadgnuradio-676acd5cc47828bc92c2fad1e474a39aacbd2ba4.tar.gz
gnuradio-676acd5cc47828bc92c2fad1e474a39aacbd2ba4.tar.bz2
gnuradio-676acd5cc47828bc92c2fad1e474a39aacbd2ba4.zip
Merged jcorgan/ezdop into trunk.
git-svn-id: http://gnuradio.org/svn/gnuradio/trunk@3264 221aa14e-8319-0410-a670-987f0aec2ac5
Diffstat (limited to 'ezdop/src/host/hunter/configure.ac')
-rw-r--r--ezdop/src/host/hunter/configure.ac42
1 files changed, 42 insertions, 0 deletions
diff --git a/ezdop/src/host/hunter/configure.ac b/ezdop/src/host/hunter/configure.ac
new file mode 100644
index 000000000..b6bd4cf7e
--- /dev/null
+++ b/ezdop/src/host/hunter/configure.ac
@@ -0,0 +1,42 @@
+# -*- Autoconf -*-
+# Process this file with autoconf to produce a configure script.
+
+AC_PREREQ(2.59)
+AC_INIT(hunter, 0.1svn, jcorgan@aeinet.com)
+AM_INIT_AUTOMAKE
+
+AC_CONFIG_SRCDIR([src/hunter.cc])
+AC_CONFIG_HEADER([config.h])
+
+# Checks for programs.
+AC_PROG_CXX
+AC_PROG_CC
+
+# Checks for libraries.
+
+# Checks for header files.
+AC_CHECK_HEADERS([fcntl.h sys/ioctl.h termios.h unistd.h])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_HEADER_STDBOOL
+AC_C_CONST
+AC_C_INLINE
+AC_TYPE_SIZE_T
+AC_STRUCT_TM
+
+# Checks for library functions.
+AC_PROG_GCC_TRADITIONAL
+AC_HEADER_STDC
+AC_FUNC_MKTIME
+AC_CHECK_FUNCS([modf sqrt])
+
+# Application specific checks
+HUNTER_WX
+HUNTER_FTDI
+
+AC_CONFIG_FILES([ \
+ Makefile
+ src/Makefile
+])
+
+AC_OUTPUT