summaryrefslogtreecommitdiff
path: root/docs/sphinx/CMakeLists.txt
diff options
context:
space:
mode:
authorTom Rondeau2012-05-21 15:32:05 -0400
committerTom Rondeau2012-05-21 15:32:05 -0400
commit5d33373a99265bc075bddb95c1e7b06a2e176cbd (patch)
tree029cee44e91b70acda19942edc83674dbdab854f /docs/sphinx/CMakeLists.txt
parented838eb9be22d769247a9c63f23423c8c2f81f72 (diff)
parentf684f3c3997b973a914b3c1adffc3ba616f0f49b (diff)
downloadgnuradio-5d33373a99265bc075bddb95c1e7b06a2e176cbd.tar.gz
gnuradio-5d33373a99265bc075bddb95c1e7b06a2e176cbd.tar.bz2
gnuradio-5d33373a99265bc075bddb95c1e7b06a2e176cbd.zip
Merge branch 'sphinxdocs'
Diffstat (limited to 'docs/sphinx/CMakeLists.txt')
-rw-r--r--docs/sphinx/CMakeLists.txt35
1 files changed, 35 insertions, 0 deletions
diff --git a/docs/sphinx/CMakeLists.txt b/docs/sphinx/CMakeLists.txt
new file mode 100644
index 000000000..38d77fb3a
--- /dev/null
+++ b/docs/sphinx/CMakeLists.txt
@@ -0,0 +1,35 @@
+# Copyright 2012 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+
+include(GrPython)
+
+configure_file(
+ ${CMAKE_CURRENT_SOURCE_DIR}/source/conf.py.in
+ ${CMAKE_CURRENT_BINARY_DIR}/conf.py
+@ONLY)
+
+configure_file(
+ ${CMAKE_CURRENT_SOURCE_DIR}/run_sphinx_build.sh.in
+ ${CMAKE_BINARY_DIR}/run_sphinx_build.sh
+@ONLY)
+
+if(UNIX)
+ #make the shell file executable
+ execute_process(COMMAND chmod +x ${CMAKE_BINARY_DIR}/run_sphinx_build.sh)
+endif(UNIX)