summaryrefslogtreecommitdiff
path: root/docs/doxygen/doxyxml/Makefile.am
diff options
context:
space:
mode:
authorJosh Blum2011-10-20 09:41:07 -0700
committerJosh Blum2011-11-16 20:38:30 -0800
commitde849caeb9d689ab0ffd9d8279ba0cb1af925753 (patch)
treebe4b7ab8b47c4ba918c54c97064f7d4929b436a1 /docs/doxygen/doxyxml/Makefile.am
parent9a25332b706b1ffadf8cdf9b405e89c37a1e2278 (diff)
downloadgnuradio-de849caeb9d689ab0ffd9d8279ba0cb1af925753.tar.gz
gnuradio-de849caeb9d689ab0ffd9d8279ba0cb1af925753.tar.bz2
gnuradio-de849caeb9d689ab0ffd9d8279ba0cb1af925753.zip
docs: grabbed support files from ben's repo and my repo
Diffstat (limited to 'docs/doxygen/doxyxml/Makefile.am')
-rw-r--r--docs/doxygen/doxyxml/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/docs/doxygen/doxyxml/Makefile.am b/docs/doxygen/doxyxml/Makefile.am
new file mode 100644
index 000000000..141f46e5a
--- /dev/null
+++ b/docs/doxygen/doxyxml/Makefile.am
@@ -0,0 +1,52 @@
+#
+# Copyright 2007,2009,2011 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GNU Radio; see the file COPYING. If not, write to
+# the Free Software Foundation, Inc., 51 Franklin Street,
+# Boston, MA 02110-1301, USA.
+#
+
+include $(top_srcdir)/Makefile.common
+
+EXTRA_DIST = \
+ example/aadvark.cc \
+ example/aadvark.h \
+ example/Doxyfile \
+ example/xml/aadvark_8cc.xml \
+ example/xml/aadvark_8h.xml \
+ example/xml/classAadvark.xml \
+ example/xml/combine.xslt \
+ example/xml/compound.xsd \
+ example/xml/index.xml \
+ example/xml/index.xsd
+
+if PYTHON
+utilspythondir = $(grpythondir)/doxyxml
+
+TESTS = \
+ run_tests
+
+nobase_utilspython_PYTHON = \
+ __init__.py \
+ base.py \
+ doxyindex.py \
+ text.py \
+ generated/__init__.py \
+ generated/index.py \
+ generated/indexsuper.py \
+ generated/compound.py \
+ generated/compoundsuper.py
+endif \ No newline at end of file