summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJosh Blum2011-02-26 14:48:34 -0800
committerJosh Blum2011-02-27 19:52:10 -0800
commit8e5f4bc89af1682b258ecb1bc46b04d24ea3addd (patch)
treeb4600aeb03b5ea59652cc7fdc8dddf578368fae8 /configure.ac
parenta02bb131f68d5aa66093310c393562671e389778 (diff)
downloadgnuradio-8e5f4bc89af1682b258ecb1bc46b04d24ea3addd.tar.gz
gnuradio-8e5f4bc89af1682b258ecb1bc46b04d24ea3addd.tar.bz2
gnuradio-8e5f4bc89af1682b258ecb1bc46b04d24ea3addd.zip
use boost::math::trunc in gr_frequency_modulator_fc.cc
this replaces the need for a conditional trunc implementation in config.h
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 0 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 7546eb302..9deffbbff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -219,20 +219,11 @@ AC_CHECK_LIB(m, sincos, [AC_DEFINE([HAVE_SINCOS],[1],[Define to 1 if your system
AC_CHECK_LIB(m, sincosf,[AC_DEFINE([HAVE_SINCOSF],[1],[Define to 1 if your system has `sincosf'.])])
AC_CHECK_LIB(m, sinf, [AC_DEFINE([HAVE_SINF],[1],[Define to 1 if your system has `sinf'.])])
AC_CHECK_LIB(m, cosf, [AC_DEFINE([HAVE_COSF],[1],[Define to 1 if your system has `cosf'.])])
-AC_CHECK_LIB(m, trunc, [AC_DEFINE([HAVE_TRUNC],[1],[Define to 1 if your system has `trunc'.])])
AC_CHECK_LIB(m, exp10, [AC_DEFINE([HAVE_EXP10],[1],[Define to 1 if your system has 'exp10'.])])
AC_CHECK_LIB(m, log2, [AC_DEFINE([HAVE_LOG2],[1],[Define to 1 if your system has 'log2'.])])
#AC_FUNC_MKTIME
AH_BOTTOM([
-#ifndef HAVE_TRUNC
-#include <math.h>
-inline static double trunc(double x)
-{
- return x >= 0 ? floor(x) : ceil(x);
-}
-#endif
-
#ifndef HAVE_EXP10
#include <math.h>
inline static double exp10(double x)