summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohnathan Corgan2010-05-24 21:26:34 -0700
committerJohnathan Corgan2010-05-24 21:26:34 -0700
commit7c50ceb026eaa26fccd438cbb8f915a29a06eaa5 (patch)
tree2d7e6b5a752209e3f870960fde5a8ba20aeb0833 /configure.ac
parent16c0a87dc5c53ca28071b76f50b31317d4c519f1 (diff)
parent6c0f2f5a5e4eddefc52c272c4b92065a225be3c5 (diff)
downloadgnuradio-7c50ceb026eaa26fccd438cbb8f915a29a06eaa5.tar.gz
gnuradio-7c50ceb026eaa26fccd438cbb8f915a29a06eaa5.tar.bz2
gnuradio-7c50ceb026eaa26fccd438cbb8f915a29a06eaa5.zip
Merge branch 'master' into next
* master: gnuradio-core: update copyrights gnuradio-core: allow swig to handle exceptions in UDP source/sink grc: update UDP source and sink block wrappers Simplify USE_SELECT usage Return immediately when using d_residual. Defend against a peer that sends an invalid message length. Move initialization of select timeout Correct update of d_temp_offset (parallel construction) Identify memory leaks that occur on error conditions Use -1 as file descriptor "not open" value instead of 0 Add additional conditionalization of networking includes Flush pending errors in gr_udp_sink on disconnect() Rework UDP source and sink, with incompatible API changes Updates to udp source/sink (select(), wait, cleanup) Discard data in gr_udp_sink until receiver is started. Use getaddrinfo in gr_udp_{source,sink} Changes to gr_udp_{source,sink} for MinGW Ignore ENOPROTOOPT return from setsockopt(SO_LINGER)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 124485bea..c912d9891 100644
--- a/configure.ac
+++ b/configure.ac
@@ -170,9 +170,9 @@ AC_HEADER_SYS_WAIT
AC_CHECK_HEADERS(fcntl.h limits.h strings.h time.h sys/ioctl.h sys/time.h unistd.h)
AC_CHECK_HEADERS(linux/ppdev.h dev/ppbus/ppi.h sys/mman.h sys/select.h sys/types.h)
AC_CHECK_HEADERS(sys/resource.h stdint.h sched.h signal.h sys/syscall.h malloc.h)
-AC_CHECK_HEADERS(netinet/in.h)
AC_CHECK_HEADERS(windows.h)
AC_CHECK_HEADERS(vec_types.h)
+AC_CHECK_HEADERS(netdb.h netinet/in.h arpa/inet.h sys/types.h sys/socket.h)
dnl Checks for typedefs, structures, and compiler characteristics.
AC_C_CONST