summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohnathan Corgan2010-04-26 13:05:03 -0700
committerJohnathan Corgan2010-04-26 13:05:03 -0700
commit665d7a850eeb46bfc6388a98e4a4107648cb6add (patch)
tree722736b80651cd2b6fbde49c7859af50b94d3621 /configure.ac
parenta3278070d3e991ea0a8f6e62bbfc2a2e177fe8e7 (diff)
parenta40feb1dece1b8064f3f81e669f3ed38b60b6dd8 (diff)
downloadgnuradio-665d7a850eeb46bfc6388a98e4a4107648cb6add.tar.gz
gnuradio-665d7a850eeb46bfc6388a98e4a4107648cb6add.tar.bz2
gnuradio-665d7a850eeb46bfc6388a98e4a4107648cb6add.zip
Merge branch 'wip/remove-mld-threads'
* wip/remove-mld-threads: Further updates for removing omnithreads Update build configuration for OSX omnithreads changeover initial move from mld_threads to gruel:: namespace threads and such Initial changes to remove mld_thread and instead use gruel:: namespace classes
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3ba5bb387..3abdfbfcf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006,2007,2008,2009 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2007,2008,2009,2010 Free Software Foundation, Inc.
dnl
dnl This file is part of GNU Radio
dnl
@@ -264,7 +264,17 @@ dnl We require the boost headers, thread lib and date_time lib.
dnl AX_BOOST_BASE finds the headers and the lib dir (-L<foo>)
dnl
dnl calls AC_SUBST(BOOST_CPPFLAGS), AC_SUBST(BOOST_LDFLAGS) and defines HAVE_BOOST
-AX_BOOST_BASE([1.35])
+dnl
+dnl Current Boost version requirement is >=1.35 for all platforms except Darwin,
+dnl which requires >=1.37 for code in usrp host library.
+case "$host_os" in
+ darwin*)
+ AX_BOOST_BASE([1.37])
+ ;;
+ *)
+ AX_BOOST_BASE([1.35])
+ ;;
+esac
dnl calls AC_SUBST(BOOST_THREAD_LIB), AC_SUBST(BOOST_CXXFLAGS) and defines HAVE_BOOST_THREAD
AX_BOOST_THREAD