summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohnathan Corgan2010-04-26 09:13:17 -0700
committerJohnathan Corgan2010-04-26 09:13:17 -0700
commit1eb2ad3909a0ba16e8c03776d1d26693b9b152a5 (patch)
tree289eeb68d9281b0b99c999d4c6f89621f3efc45f /configure.ac
parenta712b478c2824396408b2ec11584b7d559015b25 (diff)
downloadgnuradio-1eb2ad3909a0ba16e8c03776d1d26693b9b152a5.tar.gz
gnuradio-1eb2ad3909a0ba16e8c03776d1d26693b9b152a5.tar.bz2
gnuradio-1eb2ad3909a0ba16e8c03776d1d26693b9b152a5.zip
Update build configuration for OSX omnithreads changeover
gr-audio-osx now depends on gruel (via gnuradio-core) vs. omnithreads usrp now depends on gruel vs. omnithreads Boost base library dependency has been upped to 1.37 for Darwin only, for Darwin specific code in usrp host library
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 12 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 3ba5bb387..3abdfbfcf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-dnl Copyright 2001,2002,2003,2004,2005,2006,2007,2008,2009 Free Software Foundation, Inc.
+dnl Copyright 2001,2002,2003,2004,2005,2006,2007,2008,2009,2010 Free Software Foundation, Inc.
dnl
dnl This file is part of GNU Radio
dnl
@@ -264,7 +264,17 @@ dnl We require the boost headers, thread lib and date_time lib.
dnl AX_BOOST_BASE finds the headers and the lib dir (-L<foo>)
dnl
dnl calls AC_SUBST(BOOST_CPPFLAGS), AC_SUBST(BOOST_LDFLAGS) and defines HAVE_BOOST
-AX_BOOST_BASE([1.35])
+dnl
+dnl Current Boost version requirement is >=1.35 for all platforms except Darwin,
+dnl which requires >=1.37 for code in usrp host library.
+case "$host_os" in
+ darwin*)
+ AX_BOOST_BASE([1.37])
+ ;;
+ *)
+ AX_BOOST_BASE([1.35])
+ ;;
+esac
dnl calls AC_SUBST(BOOST_THREAD_LIB), AC_SUBST(BOOST_CXXFLAGS) and defines HAVE_BOOST_THREAD
AX_BOOST_THREAD