summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorTim O'Shea2012-12-07 09:28:41 -0800
committerJohnathan Corgan2012-12-07 09:36:19 -0800
commit52ca5e2765b7a4532d26502b5b76b7c85c5019d7 (patch)
tree27901f998f00d4c824c060723fab9d397931aeb3 /CMakeLists.txt
parent69990c3fb6d4c7a0daee0229407241aa1959095a (diff)
downloadgnuradio-52ca5e2765b7a4532d26502b5b76b7c85c5019d7.tar.gz
gnuradio-52ca5e2765b7a4532d26502b5b76b7c85c5019d7.tar.bz2
gnuradio-52ca5e2765b7a4532d26502b5b76b7c85c5019d7.zip
core: added gr_tuntap_pdu, gr_socket_pdu, and msg passing enhancements
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9af8d7eb9..bc076b9e7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -50,6 +50,13 @@ SET(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -O2")
SET(CMAKE_C_FLAGS_DEBUG "${CMAKE_C_FLAGS_DEBUG} -O2")
########################################################################
+# Environment setup
+########################################################################
+IF(NOT DEFINED BOOST_ROOT)
+ SET(BOOST_ROOT ${CMAKE_INSTALL_PREFIX})
+ENDIF()
+
+########################################################################
# Import executables from a native build (for cross compiling)
# http://www.vtk.org/Wiki/CMake_Cross_Compiling#Using_executables_in_the_build_created_during_the_build
########################################################################