summaryrefslogtreecommitdiff
path: root/Windows/spice/tests/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Windows/spice/tests/Makefile.am')
-rw-r--r--Windows/spice/tests/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/Windows/spice/tests/Makefile.am b/Windows/spice/tests/Makefile.am
new file mode 100644
index 00000000..8b896304
--- /dev/null
+++ b/Windows/spice/tests/Makefile.am
@@ -0,0 +1,50 @@
+## Process this file with automake to produce Makefile.in
+
+SUBDIRS = \
+ bsim3 \
+ bsim4 \
+ bsimsoi \
+ hisim \
+ hisimhv1 \
+ regression
+
+if XSPICE_WANTED
+SUBDIRS += xspice
+endif
+
+
+DIST_SUBDIRS = \
+ bsim1 \
+ bsim2 \
+ bsim3 \
+ bsim3soidd \
+ bsim3soifd \
+ bsim3soipd \
+ bsim4 \
+ bsimsoi \
+ filters \
+ general \
+ hfet \
+ hisim \
+ hisimhv1 \
+ jfet \
+ mes \
+ mesa \
+ mos6 \
+ polezero \
+ regression \
+ resistance \
+ sensitivity \
+ transient \
+ transmission \
+ vbic \
+ xspice
+
+
+TESTS_ENVIRONMENT = \
+ $(SHELL) $(top_srcdir)/tests/bin/check.sh $(top_builddir)/src/ngspice
+
+EXTRA_DIST = \
+ README bin .gitignore
+
+MAINTAINERCLEANFILES = Makefile.in