summaryrefslogtreecommitdiff
path: root/src/c/string/disp/Makefile.am
diff options
context:
space:
mode:
authorSiddhesh Wani2015-05-25 14:46:31 +0530
committerSiddhesh Wani2015-05-25 14:46:31 +0530
commitdb464f35f5a10b58d9ed1085e0b462689adee583 (patch)
treede5cdbc71a54765d9fec33414630ae2c8904c9b8 /src/c/string/disp/Makefile.am
downloadScilab2C_fossee_old-db464f35f5a10b58d9ed1085e0b462689adee583.tar.gz
Scilab2C_fossee_old-db464f35f5a10b58d9ed1085e0b462689adee583.tar.bz2
Scilab2C_fossee_old-db464f35f5a10b58d9ed1085e0b462689adee583.zip
Original Version
Diffstat (limited to 'src/c/string/disp/Makefile.am')
-rw-r--r--src/c/string/disp/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/src/c/string/disp/Makefile.am b/src/c/string/disp/Makefile.am
new file mode 100644
index 0000000..bafafee
--- /dev/null
+++ b/src/c/string/disp/Makefile.am
@@ -0,0 +1,52 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2007-2008 - INRIA - Bruno JOFRET
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+libDisp_la_CFLAGS = -I $(top_builddir)/src/c/type \
+ -I $(top_builddir)/src/c/string/includes
+
+pkglib_LTLIBRARIES = libDisp.la
+
+libDisp_la_SOURCES = $(HEAD) $(SRC)
+
+SRC = sdisps.c \
+ ddisps.c \
+ cdisps.c \
+ zdisps.c \
+ sdispa.c \
+ ddispa.c \
+ cdispa.c \
+ zdispa.c
+
+HEAD = ../includes/disp.h
+
+####
+# Checking Part
+####
+
+check_INCLUDES = -I $(top_builddir)/src/c/string/includes \
+ -I $(top_builddir)/src/c/type
+
+check_LDADD = $(top_builddir)/src/c/type/libDoubleComplex.la \
+ $(top_builddir)/src/c/type/libFloatComplex.la \
+ $(top_builddir)/src/c/string/disp/libDisp.la
+
+check_PROGRAMS = testDisp
+
+TESTS = testDisp
+
+#
+# -*- Dispine Tests -*-
+#
+testDisp_SOURCES = testDisp.c
+testDisp_CFLAGS = $(check_INCLUDES)
+testDisp_LDADD = $(check_LDADD)
+