summaryrefslogtreecommitdiff
path: root/src/c/signalProcessing/conv2d/Makefile.am
diff options
context:
space:
mode:
authorAnkit Raj2017-06-21 10:26:59 +0530
committerAnkit Raj2017-06-21 10:26:59 +0530
commit958577cac90a99124cd673fde1926781d966d91f (patch)
tree134d9fe7f5b97a647cb055bb7b4c21820a749f49 /src/c/signalProcessing/conv2d/Makefile.am
downloadScilab2C_fossee_old-958577cac90a99124cd673fde1926781d966d91f.tar.gz
Scilab2C_fossee_old-958577cac90a99124cd673fde1926781d966d91f.tar.bz2
Scilab2C_fossee_old-958577cac90a99124cd673fde1926781d966d91f.zip
Updated Scilab2C
Diffstat (limited to 'src/c/signalProcessing/conv2d/Makefile.am')
-rw-r--r--src/c/signalProcessing/conv2d/Makefile.am64
1 files changed, 64 insertions, 0 deletions
diff --git a/src/c/signalProcessing/conv2d/Makefile.am b/src/c/signalProcessing/conv2d/Makefile.am
new file mode 100644
index 0000000..ac53db6
--- /dev/null
+++ b/src/c/signalProcessing/conv2d/Makefile.am
@@ -0,0 +1,64 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2008 - INRIA - Arnaud TORSET
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+
+
+
+libConv2d_la_CFLAGS = -I $(top_builddir)/src/c/type \
+ -I $(top_builddir)/src/c/operations/includes \
+ -I $(top_builddir)/src/c/signalProcessing/includes
+
+
+instdir = $(top_builddir)/lib
+
+
+pkglib_LTLIBRARIES = libConv2d.la
+
+HEAD = ../includes/conv2d.h
+
+libConv2d_la_SOURCES = $(HEAD) \
+ sconv2da.c \
+ dconv2da.c \
+ cconv2da.c \
+ zconv2da.c
+
+
+###############
+#### Check ####
+###############
+
+check_LDADD = $(top_builddir)/src/c/type/libDoubleComplex.la \
+ $(top_builddir)/src/c/type/libFloatComplex.la \
+ $(top_builddir)/src/c/operations/multiplication/libMultiplication.la \
+ $(top_builddir)/src/c/operations/addition/libAddition.la \
+ libConv2d.la
+
+
+
+check_INCLUDES = -I $(top_builddir)/src/c/type \
+ -I $(top_builddir)/src/c/operations/includes \
+ -I $(top_builddir)/src/c/signalProcessing/includes
+
+check_PROGRAMS = testFloatConv2d testDoubleConv2d
+
+TESTS = testFloatConv2d testDoubleConv2d
+
+testDoubleConv2d_SOURCES = testDoubleConv2d.c
+testDoubleConv2d_LDADD = $(check_LDADD)
+testDoubleConv2d_CFLAGS = $(check_INCLUDES)
+
+testFloatConv2d_SOURCES = testFloatConv2d.c
+testFloatConv2d_LDADD = $(check_LDADD)
+testFloatConv2d_CFLAGS = $(check_INCLUDES)
+
+
+