summaryrefslogtreecommitdiff
path: root/src/c/operations/multiplication/Makefile.am
diff options
context:
space:
mode:
authorSandeep Gupta2017-06-18 23:55:40 +0530
committerSandeep Gupta2017-06-18 23:55:40 +0530
commit277d1edfa17bf3719d90ddbac8e31f6181e952c3 (patch)
tree0661f1f52af0a0fd654edd4984c30e57037303c6 /src/c/operations/multiplication/Makefile.am
downloadScilab2C_fossee_old-277d1edfa17bf3719d90ddbac8e31f6181e952c3.tar.gz
Scilab2C_fossee_old-277d1edfa17bf3719d90ddbac8e31f6181e952c3.tar.bz2
Scilab2C_fossee_old-277d1edfa17bf3719d90ddbac8e31f6181e952c3.zip
First commit
Diffstat (limited to 'src/c/operations/multiplication/Makefile.am')
-rw-r--r--src/c/operations/multiplication/Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/src/c/operations/multiplication/Makefile.am b/src/c/operations/multiplication/Makefile.am
new file mode 100644
index 0000000..3cc347e
--- /dev/null
+++ b/src/c/operations/multiplication/Makefile.am
@@ -0,0 +1,58 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2006-2008 - INRIA - Bruno JOFRET
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+libMultiplication_la_CFLAGS = -I $(top_builddir)/src/c/type \
+ -I $(top_builddir)/src/c/matrixOperations/includes \
+ -I $(top_builddir)/src/c/operations/includes
+
+instdir = $(top_builddir)/lib
+
+pkglib_LTLIBRARIES = libMultiplication.la
+
+HEAD = ../includes/multiplication.h
+
+libMultiplication_la_SOURCES = $(HEAD) \
+ smuls.c \
+ dmuls.c \
+ cmuls.c \
+ zmuls.c \
+ smula.c \
+ dmula.c \
+ cmula.c \
+ zmula.c \
+ smulv.c \
+ dmulv.c \
+ cmulv.c \
+ zmulv.c \
+ zmulzdv.c \
+ zmuldzv.c \
+ cmulcsv.c \
+ cmulscv.c
+
+
+check_PROGRAMS = testMultiplication
+
+check_LDADD = $(top_builddir)/src/c/type/libDoubleComplex.la \
+ $(top_builddir)/src/c/type/libFloatComplex.la \
+ $(top_builddir)/src/c/matrixOperations/zeros/libMatrixZeros.la \
+ $(top_builddir)/src/c/operations/addition/libAddition.la \
+ libMultiplication.la
+
+check_INCLUDES = -I $(top_builddir)/src/c/type \
+ -I $(top_builddir)/src/c/matrixOperations/includes \
+ -I $(top_builddir)/src/c/operations/includes
+
+testMultiplication_SOURCES = testMultiplication.c
+testMultiplication_LDADD = $(check_LDADD)
+testMultiplication_CFLAGS = $(check_INCLUDES)
+
+TESTS = testMultiplication