summaryrefslogtreecommitdiff
path: root/src/c/matrixOperations/jmat/Makefile.am
diff options
context:
space:
mode:
authorSiddhesh Wani2015-05-25 14:46:31 +0530
committerSiddhesh Wani2015-05-25 14:46:31 +0530
commitdb464f35f5a10b58d9ed1085e0b462689adee583 (patch)
treede5cdbc71a54765d9fec33414630ae2c8904c9b8 /src/c/matrixOperations/jmat/Makefile.am
downloadScilab2C_fossee_old-db464f35f5a10b58d9ed1085e0b462689adee583.tar.gz
Scilab2C_fossee_old-db464f35f5a10b58d9ed1085e0b462689adee583.tar.bz2
Scilab2C_fossee_old-db464f35f5a10b58d9ed1085e0b462689adee583.zip
Original Version
Diffstat (limited to 'src/c/matrixOperations/jmat/Makefile.am')
-rw-r--r--src/c/matrixOperations/jmat/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/src/c/matrixOperations/jmat/Makefile.am b/src/c/matrixOperations/jmat/Makefile.am
new file mode 100644
index 0000000..08afef5
--- /dev/null
+++ b/src/c/matrixOperations/jmat/Makefile.am
@@ -0,0 +1,35 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2008-2008 - INRIA - Arnaud TORSET
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+libJmat_la_CFLAGS= -I $(top_builddir)/src/c/matrixOperations/includes
+
+instdir = $(top_builddir)/lib
+
+pkglib_LTLIBRARIES = libJmat.la
+
+HEAD = ../includes/jmat.h
+
+libJmat_la_SOURCES = $(HEAD) \
+ sjmata.c \
+ djmata.c
+
+check_PROGRAMS = testJmat
+
+check_LDADD = libJmat.la
+
+check_INCLUDES = -I $(top_builddir)/src/c/matrixOperations/includes
+
+testJmat_SOURCES = testJmat.c
+testJmat_LDADD = $(check_LDADD)
+testJmat_CFLAGS = $(check_INCLUDES)
+
+TESTS = testJmat