summaryrefslogtreecommitdiff
path: root/src/c/auxiliaryFunctions/size/Makefile.am
diff options
context:
space:
mode:
authorSiddhesh Wani2015-05-25 14:46:31 +0530
committerSiddhesh Wani2015-05-25 14:46:31 +0530
commitdb464f35f5a10b58d9ed1085e0b462689adee583 (patch)
treede5cdbc71a54765d9fec33414630ae2c8904c9b8 /src/c/auxiliaryFunctions/size/Makefile.am
downloadScilab2C_fossee_old-db464f35f5a10b58d9ed1085e0b462689adee583.tar.gz
Scilab2C_fossee_old-db464f35f5a10b58d9ed1085e0b462689adee583.tar.bz2
Scilab2C_fossee_old-db464f35f5a10b58d9ed1085e0b462689adee583.zip
Original Version
Diffstat (limited to 'src/c/auxiliaryFunctions/size/Makefile.am')
-rw-r--r--src/c/auxiliaryFunctions/size/Makefile.am37
1 files changed, 37 insertions, 0 deletions
diff --git a/src/c/auxiliaryFunctions/size/Makefile.am b/src/c/auxiliaryFunctions/size/Makefile.am
new file mode 100644
index 0000000..e7eaaca
--- /dev/null
+++ b/src/c/auxiliaryFunctions/size/Makefile.am
@@ -0,0 +1,37 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2008-2008 - INRIA - Bruno JOFRET
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+libSize_la_CFLAGS = -I ../../type \
+ -I ../includes
+
+instdir = $(top_builddir)/lib
+
+####
+# Checking Part
+####
+
+check_INCLUDES = -I $(top_builddir)/src/c/auxiliaryFunctions/includes \
+ -I $(top_builddir)/src/c/type
+
+check_PROGRAMS = testSize
+
+TESTS = testSize
+
+#
+# -*- Size Tests -*-
+#
+testSize_SOURCES = testSize.h testSize.c
+testSize_CFLAGS = $(check_INCLUDES)
+testSize_LDADD = $(top_builddir)/src/c/type/libDoubleComplex.la \
+ $(top_builddir)/src/c/type/libFloatComplex.la \
+ $(top_builddir)/src/c/auxiliaryFunctions/size/libSize.la \
+ @LIBMATH@