summaryrefslogtreecommitdiff
path: root/src/c/auxiliaryFunctions/pythag/Makefile.am
diff options
context:
space:
mode:
authorSiddhesh Wani2015-05-25 14:46:31 +0530
committerSiddhesh Wani2015-05-25 14:46:31 +0530
commitdb464f35f5a10b58d9ed1085e0b462689adee583 (patch)
treede5cdbc71a54765d9fec33414630ae2c8904c9b8 /src/c/auxiliaryFunctions/pythag/Makefile.am
downloadScilab2C_fossee_old-db464f35f5a10b58d9ed1085e0b462689adee583.tar.gz
Scilab2C_fossee_old-db464f35f5a10b58d9ed1085e0b462689adee583.tar.bz2
Scilab2C_fossee_old-db464f35f5a10b58d9ed1085e0b462689adee583.zip
Original Version
Diffstat (limited to 'src/c/auxiliaryFunctions/pythag/Makefile.am')
-rw-r--r--src/c/auxiliaryFunctions/pythag/Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/src/c/auxiliaryFunctions/pythag/Makefile.am b/src/c/auxiliaryFunctions/pythag/Makefile.am
new file mode 100644
index 0000000..4cf06ea
--- /dev/null
+++ b/src/c/auxiliaryFunctions/pythag/Makefile.am
@@ -0,0 +1,58 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2007-2008 - INRIA - Bruno JOFRET
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+libPythag_la_CFLAGS = -I $(top_builddir)/src/c/type \
+ -I $(top_builddir)/src/c/auxiliaryFunctions/includes \
+ -I $(top_builddir)/src/c/elementaryFunctions/includes \
+ -I $(top_builddir)/src/c/operations/includes
+
+instdir = $(top_builddir)/lib
+
+pkglib_LTLIBRARIES = libPythag.la
+
+libPythag_la_SOURCES = $(HEAD) $(SRC)
+
+SRC = spythags.c \
+ dpythags.c \
+ cpythags.c \
+ zpythags.c
+
+HEAD = ../includes/pythag.h
+
+####
+# Checking Part
+####
+
+check_INCLUDES = -I $(top_builddir)/src/c/auxiliaryFunctions/includes \
+ -I $(top_builddir)/src/c/elementaryFunctions/includes \
+ -I $(top_builddir)/src/c/operations/includes \
+ -I $(top_builddir)/src/c/type
+
+check_PROGRAMS = testPythag
+
+TESTS = testPythag
+
+#
+# -*- Pythag Tests -*-
+#
+testPythag_SOURCES = testPythag.h testPythag.c
+testPythag_CFLAGS = $(check_INCLUDES)
+testPythag_LDADD = $(top_builddir)/src/c/type/libFloatComplex.la \
+ $(top_builddir)/src/c/type/libDoubleComplex.la \
+ $(top_builddir)/src/c/operations/addition/libAddition.la \
+ $(top_builddir)/src/fortran/lapack/libscilapack.la \
+ $(top_builddir)/src/c/auxiliaryFunctions/pythag/libPythag.la \
+ $(top_builddir)/src/c/elementaryFunctions/sqrt/libSqrt.la \
+ $(top_builddir)/src/c/auxiliaryFunctions/abs/libAbs.la \
+ $(top_builddir)/src/c/auxiliaryFunctions/pythag/libPythag.la \
+ $(top_builddir)/src/c/operations/multiplication/libMultiplication.la \
+ @LIBMATH@