summaryrefslogtreecommitdiff
path: root/2.3-1/src/c/matrixOperations/cat/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '2.3-1/src/c/matrixOperations/cat/Makefile.am')
-rw-r--r--2.3-1/src/c/matrixOperations/cat/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/2.3-1/src/c/matrixOperations/cat/Makefile.am b/2.3-1/src/c/matrixOperations/cat/Makefile.am
new file mode 100644
index 00000000..fd315ddc
--- /dev/null
+++ b/2.3-1/src/c/matrixOperations/cat/Makefile.am
@@ -0,0 +1,52 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2006-2008 - INRIA - Bruno JOFRET
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+libMatrixConcatenation_la_CFLAGS = -I $(top_builddir)/src/c/type \
+ -I $(top_builddir)/src/c/matrixOperations/includes
+
+instdir = $(top_builddir)/lib
+
+pkglib_LTLIBRARIES = libMatrixConcatenation.la
+
+HEAD = ../includes/cat.h
+
+libMatrixConcatenation_la_SOURCES = $(HEAD) \
+ scats.c \
+ scata.c \
+ dcats.c \
+ dcata.c \
+ ccats.c \
+ ccata.c \
+ zcats.c \
+ zcata.c
+
+check_PROGRAMS = testFloatMatrixConcatenation \
+ testDoubleMatrixConcatenation
+
+check_LDADD = $(top_builddir)/src/c/type/libDoubleComplex.la \
+ $(top_builddir)/src/c/type/libFloatComplex.la \
+ $(top_builddir)/src/fortran/blas/libsciblas.la \
+ libMatrixConcatenation.la
+
+check_INCLUDES = -I $(top_builddir)/src/c/type \
+ -I $(top_builddir)/src/c/matrixOperations/includes
+
+testDoubleMatrixConcatenation_SOURCES = testDoubleMatrixConcatenation.c
+testDoubleMatrixConcatenation_LDADD = $(check_LDADD)
+testDoubleMatrixConcatenation_CFLAGS = $(check_INCLUDES)
+
+testFloatMatrixConcatenation_SOURCES = testFloatMatrixConcatenation.c
+testFloatMatrixConcatenation_LDADD = $(check_LDADD)
+testFloatMatrixConcatenation_CFLAGS = $(check_INCLUDES)
+
+TESTS = testFloatMatrixConcatenation \
+ testDoubleMatrixConcatenation \ No newline at end of file