summaryrefslogtreecommitdiff
path: root/2.3-1/src/c/auxiliaryFunctions/find/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to '2.3-1/src/c/auxiliaryFunctions/find/Makefile.am')
-rw-r--r--2.3-1/src/c/auxiliaryFunctions/find/Makefile.am49
1 files changed, 49 insertions, 0 deletions
diff --git a/2.3-1/src/c/auxiliaryFunctions/find/Makefile.am b/2.3-1/src/c/auxiliaryFunctions/find/Makefile.am
new file mode 100644
index 00000000..622cc20b
--- /dev/null
+++ b/2.3-1/src/c/auxiliaryFunctions/find/Makefile.am
@@ -0,0 +1,49 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2006-2008 - INRIA - Bruno JOFRET
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+AM_CFLAGS = -I ../../type \
+ -I ../includes
+
+instdir = $(top_builddir)/lib
+
+pkglib_LTLIBRARIES = libFind.la
+
+libFind_la_SOURCES = $(HEAD) $(SRC)
+
+SRC = sfinda.c \
+ dfinda.c \
+ cfinda.c \
+ zfinda.c
+
+HEAD = ../includes/find.h \
+ ../../includes/notFound.h
+
+####
+# Checking Part
+####
+
+check_INCLUDES = -I $(top_builddir)/src/c/auxiliaryFunctions/includes \
+ -I $(top_builddir)/src/c/type
+
+check_PROGRAMS = testFind
+
+TESTS = testFind
+
+#
+# -*- Find Tests -*-
+#
+testFind_SOURCES = testFind.h testFind.c
+testFind_CFLAGS = $(check_INCLUDES)
+testFind_LDADD = $(top_builddir)/src/c/type/libDoubleComplex.la \
+ $(top_builddir)/src/c/type/libFloatComplex.la \
+ $(top_builddir)/src/c/auxiliaryFunctions/find/libFind.la \
+ @LIBMATH@