summaryrefslogtreecommitdiff
path: root/2.3-1/src/c/matrixOperations/transpose/Makefile.am
diff options
context:
space:
mode:
authoryash11122017-07-07 21:20:49 +0530
committeryash11122017-07-07 21:20:49 +0530
commit9e5793a7b05b23e6044a6d7a9ddd5db39ba375f0 (patch)
treef50d6e06d8fe6bc1a9053ef10d4b4d857800ab51 /2.3-1/src/c/matrixOperations/transpose/Makefile.am
downloadScilab2C-9e5793a7b05b23e6044a6d7a9ddd5db39ba375f0.tar.gz
Scilab2C-9e5793a7b05b23e6044a6d7a9ddd5db39ba375f0.tar.bz2
Scilab2C-9e5793a7b05b23e6044a6d7a9ddd5db39ba375f0.zip
sci2c arduino updated
Diffstat (limited to '2.3-1/src/c/matrixOperations/transpose/Makefile.am')
-rw-r--r--2.3-1/src/c/matrixOperations/transpose/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/2.3-1/src/c/matrixOperations/transpose/Makefile.am b/2.3-1/src/c/matrixOperations/transpose/Makefile.am
new file mode 100644
index 00000000..f36910f4
--- /dev/null
+++ b/2.3-1/src/c/matrixOperations/transpose/Makefile.am
@@ -0,0 +1,42 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2008-2008 - INRIA - Allan SIMON
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+libMatrixTranspose_la_CFLAGS = -I $(top_builddir)/src/c/type \
+ -I $(top_builddir)/src/c/matrixOperations/includes
+
+instdir = $(top_builddir)/lib
+
+pkglib_LTLIBRARIES = libMatrixTranspose.la
+
+HEAD = ../includes/matrixTranspose.h
+
+libMatrixTranspose_la_SOURCES = $(HEAD) \
+ stransposea.c \
+ dtransposea.c \
+ ctransposea.c \
+ ztransposea.c
+
+check_PROGRAMS = testMatrixTranspose
+
+check_LDADD = $(top_builddir)/src/c/type/libDoubleComplex.la \
+ $(top_builddir)/src/c/type/libFloatComplex.la \
+ $(top_builddir)/src/fortran/blas/libsciblas.la \
+ libMatrixTranspose.la
+
+check_INCLUDES = -I $(top_builddir)/src/c/type \
+ -I $(top_builddir)/src/c/matrixOperations/includes
+
+testMatrixTranspose_SOURCES = testMatrixTranspose.c
+testMatrixTranspose_LDADD = $(check_LDADD)
+testMatrixTranspose_CFLAGS = $(check_INCLUDES)
+
+TESTS = testMatrixTranspose