summaryrefslogtreecommitdiff
path: root/2.3-1/src/c/implicitList/Makefile.am
diff options
context:
space:
mode:
authoryash11122017-07-07 21:20:49 +0530
committeryash11122017-07-07 21:20:49 +0530
commit9e5793a7b05b23e6044a6d7a9ddd5db39ba375f0 (patch)
treef50d6e06d8fe6bc1a9053ef10d4b4d857800ab51 /2.3-1/src/c/implicitList/Makefile.am
downloadScilab2C-9e5793a7b05b23e6044a6d7a9ddd5db39ba375f0.tar.gz
Scilab2C-9e5793a7b05b23e6044a6d7a9ddd5db39ba375f0.tar.bz2
Scilab2C-9e5793a7b05b23e6044a6d7a9ddd5db39ba375f0.zip
sci2c arduino updated
Diffstat (limited to '2.3-1/src/c/implicitList/Makefile.am')
-rw-r--r--2.3-1/src/c/implicitList/Makefile.am47
1 files changed, 47 insertions, 0 deletions
diff --git a/2.3-1/src/c/implicitList/Makefile.am b/2.3-1/src/c/implicitList/Makefile.am
new file mode 100644
index 00000000..1f534798
--- /dev/null
+++ b/2.3-1/src/c/implicitList/Makefile.am
@@ -0,0 +1,47 @@
+##
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2006-2008 - INRIA - Bruno JOFRET
+##
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+libImplicitlist_la_CFLAGS = -I $(top_builddir)/src/c/type \
+ -I .
+
+instdir = $(top_builddir)/lib
+
+pkglib_LTLIBRARIES = libImplicitlist.la
+
+HEAD = implicitList.h
+
+libImplicitlist_la_SOURCES = $(HEAD) \
+ simplicitLists.c \
+ dimplicitLists.c \
+ cimplicitLists.c \
+ zimplicitLists.c
+
+check_PROGRAMS = testFloatImplicitList \
+ testDoubleImplicitList
+
+check_LDADD = $(top_builddir)/src/c/type/libDoubleComplex.la \
+ $(top_builddir)/src/c/type/libFloatComplex.la \
+ libImplicitlist.la
+
+check_INCLUDES = -I $(top_builddir)/src/c/type \
+ -I .
+
+testFloatImplicitList_SOURCES = testFloatImplicitList.c
+testFloatImplicitList_LDADD = $(check_LDADD)
+testFloatImplicitList_CFLAGS = $(check_INCLUDES)
+
+testDoubleImplicitList_SOURCES = testDoubleImplicitList.c
+testDoubleImplicitList_LDADD = $(check_LDADD)
+testDoubleImplicitList_CFLAGS = $(check_INCLUDES)
+
+TESTS = testFloatImplicitList \
+ testDoubleImplicitList