summaryrefslogtreecommitdiff
path: root/qa/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'qa/CMakeLists.txt')
-rw-r--r--qa/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/qa/CMakeLists.txt b/qa/CMakeLists.txt
new file mode 100644
index 0000000..796575d
--- /dev/null
+++ b/qa/CMakeLists.txt
@@ -0,0 +1,15 @@
+if( KICAD_SCRIPTING_MODULES )
+
+ if( APPLE AND ( KICAD_BUILD_STATIC OR KICAD_BUILD_DYNAMIC ) )
+ set( PYTHON_QA_PATH :${LIBWXPYTHON_ROOT}/wxPython/lib/python2.6/site-packages )
+ endif()
+
+ # build target that runs the QA tests through scripting
+ add_custom_target( qa
+ COMMAND PYTHONPATH=${CMAKE_BINARY_DIR}/pcbnew${PYTHON_QA_PATH} ${PYTHON_EXECUTABLE} test.py
+
+ COMMENT "running qa"
+ WORKING_DIRECTORY ${CMAKE_CURRENT_SOURCE_DIR}
+ )
+
+endif()