summaryrefslogtreecommitdiff
path: root/utils/idftools/CMakeLists.txt
diff options
context:
space:
mode:
authorsaurabhb172020-02-26 16:36:01 +0530
committersaurabhb172020-02-26 16:36:01 +0530
commit1fa449fed953fa11f6bd0ea82cc2d3b115ee0781 (patch)
treead18839d8b4eb1f13419d07878cc4ec4c9b70032 /utils/idftools/CMakeLists.txt
parentc38609295ad4b617aef472b9c575aee18710a50f (diff)
downloadKiCad-eSim-1fa449fed953fa11f6bd0ea82cc2d3b115ee0781.tar.gz
KiCad-eSim-1fa449fed953fa11f6bd0ea82cc2d3b115ee0781.tar.bz2
KiCad-eSim-1fa449fed953fa11f6bd0ea82cc2d3b115ee0781.zip
Remaining files transfered
Diffstat (limited to 'utils/idftools/CMakeLists.txt')
-rw-r--r--utils/idftools/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/utils/idftools/CMakeLists.txt b/utils/idftools/CMakeLists.txt
new file mode 100644
index 0000000..4334403
--- /dev/null
+++ b/utils/idftools/CMakeLists.txt
@@ -0,0 +1,36 @@
+include_directories(
+ "${CMAKE_SOURCE_DIR}/lib_dxf"
+ "${CMAKE_SOURCE_DIR}/utils/idftools"
+ ${OPENGL_INCLUDE_DIR}
+ ${Boost_INCLUDE_DIR}
+ )
+
+link_directories(
+ "${CMAKE_BINARY_DIR}/lib_dxf"
+ )
+
+add_library( idf3 STATIC
+ idf_helpers.cpp idf_common.cpp idf_outlines.cpp
+ idf_parser.cpp vrml_layer.cpp )
+
+add_executable( idfcyl idf_cylinder.cpp )
+add_executable( idfrect idf_rect.cpp )
+add_executable( dxf2idf dxf2idfmain.cpp dxf2idf.cpp )
+add_executable( idf2vrml idf2vrml.cpp )
+
+add_dependencies( idf2vrml boost )
+
+target_link_libraries( dxf2idf lib_dxf idf3 ${wxWidgets_LIBRARIES} )
+
+target_link_libraries( idf2vrml idf3 ${OPENGL_LIBRARIES} ${wxWidgets_LIBRARIES} )
+
+if( APPLE )
+ # puts binaries into the *.app bundle while linking
+ set_target_properties( idfcyl idfrect dxf2idf idf2vrml PROPERTIES
+ RUNTIME_OUTPUT_DIRECTORY ${OSX_BUNDLE_BUILD_BIN_DIR}
+ )
+else()
+ install( TARGETS idfcyl idfrect dxf2idf idf2vrml
+ DESTINATION ${KICAD_BIN}
+ COMPONENT binary )
+endif()