summaryrefslogtreecommitdiff
path: root/utils/idftools/CMakeLists.txt
diff options
context:
space:
mode:
authorsaurabhb172020-02-26 16:40:14 +0530
committerGitHub2020-02-26 16:40:14 +0530
commit02c614b4e64b68758f223391cb5357b3eec78cac (patch)
treead18839d8b4eb1f13419d07878cc4ec4c9b70032 /utils/idftools/CMakeLists.txt
parentb77f5d9d8097c38159c6f60917995d6af13bbe1c (diff)
parent07a8c86216b6b1f694b136ec64c281d62941952e (diff)
downloadKiCad-eSim-02c614b4e64b68758f223391cb5357b3eec78cac.tar.gz
KiCad-eSim-02c614b4e64b68758f223391cb5357b3eec78cac.tar.bz2
KiCad-eSim-02c614b4e64b68758f223391cb5357b3eec78cac.zip
Merge pull request #6 from saurabhb17/master
minor additions
Diffstat (limited to 'utils/idftools/CMakeLists.txt')
-rw-r--r--utils/idftools/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/utils/idftools/CMakeLists.txt b/utils/idftools/CMakeLists.txt
new file mode 100644
index 0000000..4334403
--- /dev/null
+++ b/utils/idftools/CMakeLists.txt
@@ -0,0 +1,36 @@
+include_directories(
+ "${CMAKE_SOURCE_DIR}/lib_dxf"
+ "${CMAKE_SOURCE_DIR}/utils/idftools"
+ ${OPENGL_INCLUDE_DIR}
+ ${Boost_INCLUDE_DIR}
+ )
+
+link_directories(
+ "${CMAKE_BINARY_DIR}/lib_dxf"
+ )
+
+add_library( idf3 STATIC
+ idf_helpers.cpp idf_common.cpp idf_outlines.cpp
+ idf_parser.cpp vrml_layer.cpp )
+
+add_executable( idfcyl idf_cylinder.cpp )
+add_executable( idfrect idf_rect.cpp )
+add_executable( dxf2idf dxf2idfmain.cpp dxf2idf.cpp )
+add_executable( idf2vrml idf2vrml.cpp )
+
+add_dependencies( idf2vrml boost )
+
+target_link_libraries( dxf2idf lib_dxf idf3 ${wxWidgets_LIBRARIES} )
+
+target_link_libraries( idf2vrml idf3 ${OPENGL_LIBRARIES} ${wxWidgets_LIBRARIES} )
+
+if( APPLE )
+ # puts binaries into the *.app bundle while linking
+ set_target_properties( idfcyl idfrect dxf2idf idf2vrml PROPERTIES
+ RUNTIME_OUTPUT_DIRECTORY ${OSX_BUNDLE_BUILD_BIN_DIR}
+ )
+else()
+ install( TARGETS idfcyl idfrect dxf2idf idf2vrml
+ DESTINATION ${KICAD_BIN}
+ COMPONENT binary )
+endif()