summaryrefslogtreecommitdiff
path: root/venv/Lib/site-packages/lazy_object_proxy-1.4.3.dist-info/METADATA
diff options
context:
space:
mode:
authorpravindalve2023-05-30 04:20:14 +0530
committerGitHub2023-05-30 04:20:14 +0530
commitcbdd7ca21f1f673a3a739065098f7cc6c9c4b881 (patch)
tree595e888c38f00a314e751096b6bf636a544a5efe /venv/Lib/site-packages/lazy_object_proxy-1.4.3.dist-info/METADATA
parent7740d1ca0c2e6bf34900460b0c58fa4d528577fb (diff)
parent280c6aa89a15331fb76b7014957953dc72af6093 (diff)
downloadChemical-Simulator-GUI-master.tar.gz
Chemical-Simulator-GUI-master.tar.bz2
Chemical-Simulator-GUI-master.zip
Merge pull request #63 from brenda-br/Fix-35HEADmaster
Restructure Project and Deployment
Diffstat (limited to 'venv/Lib/site-packages/lazy_object_proxy-1.4.3.dist-info/METADATA')
-rw-r--r--venv/Lib/site-packages/lazy_object_proxy-1.4.3.dist-info/METADATA166
1 files changed, 0 insertions, 166 deletions
diff --git a/venv/Lib/site-packages/lazy_object_proxy-1.4.3.dist-info/METADATA b/venv/Lib/site-packages/lazy_object_proxy-1.4.3.dist-info/METADATA
deleted file mode 100644
index 6b4b830..0000000
--- a/venv/Lib/site-packages/lazy_object_proxy-1.4.3.dist-info/METADATA
+++ /dev/null
@@ -1,166 +0,0 @@
-Metadata-Version: 2.1
-Name: lazy-object-proxy
-Version: 1.4.3
-Summary: A fast and thorough lazy object proxy.
-Home-page: https://github.com/ionelmc/python-lazy-object-proxy
-Author: Ionel Cristian Mărieș
-Author-email: contact@ionelmc.ro
-License: BSD-2-Clause
-Project-URL: Documentation, https://python-lazy-object-proxy.readthedocs.io/
-Project-URL: Changelog, https://python-lazy-object-proxy.readthedocs.io/en/latest/changelog.html
-Project-URL: Issue Tracker, https://github.com/ionelmc/python-lazy-object-proxy/issues
-Platform: UNKNOWN
-Classifier: Development Status :: 5 - Production/Stable
-Classifier: Intended Audience :: Developers
-Classifier: License :: OSI Approved :: BSD License
-Classifier: Operating System :: Unix
-Classifier: Operating System :: POSIX
-Classifier: Operating System :: Microsoft :: Windows
-Classifier: Programming Language :: Python
-Classifier: Programming Language :: Python :: 2.7
-Classifier: Programming Language :: Python :: 3
-Classifier: Programming Language :: Python :: 3.4
-Classifier: Programming Language :: Python :: 3.5
-Classifier: Programming Language :: Python :: 3.6
-Classifier: Programming Language :: Python :: 3.7
-Classifier: Programming Language :: Python :: 3.8
-Classifier: Programming Language :: Python :: Implementation :: CPython
-Classifier: Programming Language :: Python :: Implementation :: PyPy
-Classifier: Topic :: Utilities
-Requires-Python: >=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*
-
-========
-Overview
-========
-
-
-
-A fast and thorough lazy object proxy.
-
-* Free software: BSD 2-Clause License
-
-Note that this is based on `wrapt`_'s ObjectProxy with one big change: it calls a function the first time the proxy object is
-used, while `wrapt.ObjectProxy` just forwards the method calls to the target object.
-
-In other words, you use `lazy-object-proxy` when you only have the object way later and you use `wrapt.ObjectProxy` when you
-want to override few methods (by subclassing) and forward everything else to the target object.
-
-Example::
-
- import lazy_object_proxy
-
- def expensive_func():
- from time import sleep
- print('starting calculation')
- # just as example for a very slow computation
- sleep(2)
- print('finished calculation')
- # return the result of the calculation
- return 10
-
- obj = lazy_object_proxy.Proxy(expensive_func)
- # function is called only when object is actually used
- print(obj) # now expensive_func is called
-
- print(obj) # the result without calling the expensive_func
-
-Installation
-============
-
-::
-
- pip install lazy-object-proxy
-
-Documentation
-=============
-
-https://python-lazy-object-proxy.readthedocs.io/
-
-Development
-===========
-
-To run the all tests run::
-
- tox
-
-Acknowledgements
-================
-
-This project is based on some code from `wrapt`_ as you can see in the git history.
-
-.. _wrapt: https://github.com/GrahamDumpleton/wrapt
-
-
-Changelog
-=========
-
-1.4.3 (2019-10-26)
-------------------
-
-* Added binary wheels for Python 3.8.
-* Fixed license metadata.
-
-1.4.2 (2019-08-22)
-------------------
-
-* Included a ``pyproject.toml`` to allow users install the sdist with old python/setuptools, as the
- setuptools-scm dep will be fetched by pip instead of setuptools.
- Fixes `#30 <https://github.com/ionelmc/python-lazy-object-proxy/issues/30>`_.
-
-1.4.1 (2019-05-10)
-------------------
-
-* Fixed wheels being built with ``-coverage`` cflags. No more issues about bogus ``cext.gcda`` files.
-* Removed useless C file from wheels.
-* Changed ``setup.py`` to use setuptools-scm.
-
-1.4.0 (2019-05-05)
-------------------
-
-* Fixed ``__mod__`` for the slots backend. Contributed by Ran Benita in
- `#28 <https://github.com/ionelmc/python-lazy-object-proxy/pull/28>`_.
-* Dropped support for Python 2.6 and 3.3. Contributed by "hugovk" in
- `#24 <https://github.com/ionelmc/python-lazy-object-proxy/pull/24>`_.
-
-1.3.1 (2017-05-05)
-------------------
-
-* Fix broken release (``sdist`` had a broken ``MANIFEST.in``).
-
-1.3.0 (2017-05-02)
-------------------
-
-* Speed up arithmetic operations involving ``cext.Proxy`` subclasses.
-
-1.2.2 (2016-04-14)
-------------------
-
-* Added `manylinux <https://www.python.org/dev/peps/pep-0513/>`_ wheels.
-* Minor cleanup in readme.
-
-1.2.1 (2015-08-18)
-------------------
-
-* Fix a memory leak (the wrapped object would get bogus references). Contributed by Astrum Kuo in
- `#10 <https://github.com/ionelmc/python-lazy-object-proxy/pull/10>`_.
-
-1.2.0 (2015-07-06)
-------------------
-
-* Don't instantiate the object when __repr__ is called. This aids with debugging (allows one to see exactly in
- what state the proxy is).
-
-1.1.0 (2015-07-05)
-------------------
-
-* Added support for pickling. The pickled value is going to be the wrapped object *without* any Proxy container.
-* Fixed a memory management issue in the C extension (reference cycles weren't garbage collected due to improper
- handling in the C extension). Contributed by Alvin Chow in
- `#8 <https://github.com/ionelmc/python-lazy-object-proxy/pull/8>`_.
-
-1.0.2 (2015-04-11)
------------------------------------------
-
-* First release on PyPI.
-
-