summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Kluyver2014-06-26 17:12:02 -0700
committerThomas Kluyver2014-06-26 17:16:20 -0700
commitcb0df82ba81a8deb5743a885527542e5498a0490 (patch)
tree76ee024dd34ede6da484ffcdc030d03595a9a27b /setup.py
downloadscilab_kernel-cb0df82ba81a8deb5743a885527542e5498a0490.tar.gz
scilab_kernel-cb0df82ba81a8deb5743a885527542e5498a0490.tar.bz2
scilab_kernel-cb0df82ba81a8deb5743a885527542e5498a0490.zip
Initial commit (made in the IPython Qtconsole)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 17 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..2ff9238
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,17 @@
+from distutils.core import setup
+from distutils.command.install import install
+
+class install_with_kernelspec(install):
+ def run(self):
+ install.run(self)
+ from IPython.kernel.kernelspec import install_kernel_spec
+ install_kernel_spec('kernelspec', 'bash', replace=True)
+
+setup(name='bash_kernel',
+ version='0.1',
+ description='A bash kernel for IPython',
+ author='Thomas Kluyver',
+ author_email='thomas@kluyver.me.uk',
+ py_modules=['bash_kernel'],
+ cmdclass={'install': install_with_kernelspec}
+ ) \ No newline at end of file