From b56c1d5508edf80f36c9a48e8806641f5cdf2cd8 Mon Sep 17 00:00:00 2001
From: jofret
Date: Tue, 28 Apr 2009 06:53:00 +0000
Subject: Moving source code

---
 src/c/elementaryFunctions/lnp1m1/Makefile.am | 56 ++++++++++++++++++++++++++++
 1 file changed, 56 insertions(+)
 create mode 100644 src/c/elementaryFunctions/lnp1m1/Makefile.am

(limited to 'src/c/elementaryFunctions/lnp1m1/Makefile.am')

diff --git a/src/c/elementaryFunctions/lnp1m1/Makefile.am b/src/c/elementaryFunctions/lnp1m1/Makefile.am
new file mode 100644
index 00000000..27478fa3
--- /dev/null
+++ b/src/c/elementaryFunctions/lnp1m1/Makefile.am
@@ -0,0 +1,56 @@
+##
+##  Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+##  Copyright (C) 2008-2008 - INRIA - Bruno JOFRET
+##
+##  This file must be used under the terms of the CeCILL.
+##  This source file is licensed as described in the file COPYING, which
+##  you should have received as part of this distribution.  The terms
+##  are also available at
+##  http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+libLnp1m1_la_CFLAGS =	-I $(top_builddir)/type \
+			-I $(top_builddir)/auxiliaryFunctions/includes \
+			-I $(top_builddir)/elementaryFunctions/includes
+
+instdir = $(top_builddir)/lib
+
+pkglib_LTLIBRARIES =	libLnp1m1.la
+
+libLnp1m1_la_SOURCES =	$(HEAD) $(SRC)
+
+SRC	=	slnp1m1s.c \
+		dlnp1m1s.c
+
+HEAD	=	$(top_builddir)/elementaryFunctions/includes/lnp1m1.h
+
+####
+# Checking Part
+####
+
+check_INCLUDES	=	-I $(top_builddir)/elementaryFunctions/includes \
+			-I $(top_builddir)/type
+
+check_LDADD	=	$(top_builddir)/type/libDoubleComplex.la \
+			$(top_builddir)/type/libFloatComplex.la \
+			$(top_builddir)/operations/addition/libAddition.la \
+			$(top_builddir)/lib/lapack/libscilapack.la \
+			$(top_builddir)/elementaryFunctions/lnp1m1/libLnp1m1.la \
+			$(top_builddir)/elementaryFunctions/sqrt/libSqrt.la \
+			$(top_builddir)/auxiliaryFunctions/pythag/libPythag.la \
+			$(top_builddir)/auxiliaryFunctions/abs/libAbs.la \
+			$(top_builddir)/operations/multiplication/libMultiplication.la \
+			@LIBMATH@
+
+check_PROGRAMS	= 	testFloatLnp1m1 testDoubleLnp1m1
+
+TESTS		=	testFloatLnp1m1 testDoubleLnp1m1
+
+testFloatLnp1m1_SOURCES = 	testLnp1m1.h testFloatLnp1m1.c
+testFloatLnp1m1_CFLAGS =	$(check_INCLUDES)
+testFloatLnp1m1_LDADD =	$(check_LDADD)
+
+testDoubleLnp1m1_SOURCES = 	testLnp1m1.h testDoubleLnp1m1.c
+testDoubleLnp1m1_CFLAGS	=	$(check_INCLUDES)
+testDoubleLnp1m1_LDADD	=	$(check_LDADD)
-- 
cgit