From db464f35f5a10b58d9ed1085e0b462689adee583 Mon Sep 17 00:00:00 2001
From: Siddhesh Wani
Date: Mon, 25 May 2015 14:46:31 +0530
Subject: Original Version

---
 src/c/auxiliaryFunctions/length/Makefile.am | 37 +++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
 create mode 100644 src/c/auxiliaryFunctions/length/Makefile.am

(limited to 'src/c/auxiliaryFunctions/length/Makefile.am')

diff --git a/src/c/auxiliaryFunctions/length/Makefile.am b/src/c/auxiliaryFunctions/length/Makefile.am
new file mode 100644
index 00000000..8c51f41c
--- /dev/null
+++ b/src/c/auxiliaryFunctions/length/Makefile.am
@@ -0,0 +1,37 @@
+##
+##  Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+##  Copyright (C) 2008-2008 - INRIA - Bruno JOFRET
+##
+##  This file must be used under the terms of the CeCILL.
+##  This source file is licensed as described in the file COPYING, which
+##  you should have received as part of this distribution.  The terms
+##  are also available at
+##  http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
+##
+##
+
+libLength_la_CFLAGS =	-I ../../type \
+			-I ../includes
+
+instdir = $(top_builddir)/lib
+
+####
+# Checking Part
+####
+
+check_INCLUDES	=	-I $(top_builddir)/src/c/auxiliaryFunctions/includes \
+			-I $(top_builddir)/src/c/type
+
+check_PROGRAMS	= 	testLength
+
+TESTS		=	testLength
+
+#
+# -*- Length Tests -*-
+#
+testLength_SOURCES = 	testLength.h testLength.c
+testLength_CFLAGS	=	$(check_INCLUDES)
+testLength_LDADD	=	$(top_builddir)/src/c/type/libDoubleComplex.la \
+				$(top_builddir)/src/c/type/libFloatComplex.la \
+				$(top_builddir)/src/c/auxiliaryFunctions/length/libLength.la \
+				@LIBMATH@
-- 
cgit