summaryrefslogtreecommitdiff
path: root/src/string/string/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/string/string/Makefile.am')
-rw-r--r--src/string/string/Makefile.am52
1 files changed, 0 insertions, 52 deletions
diff --git a/src/string/string/Makefile.am b/src/string/string/Makefile.am
deleted file mode 100644
index 9dfe3ef4..00000000
--- a/src/string/string/Makefile.am
+++ /dev/null
@@ -1,52 +0,0 @@
-##
-## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
-## Copyright (C) 2008-2008 - INRIA - Allan SIMON
-##
-## This file must be used under the terms of the CeCILL.
-## This source file is licensed as described in the file COPYING, which
-## you should have received as part of this distribution. The terms
-## are also available at
-## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
-##
-##
-
-libString_la_CFLAGS = -I $(top_builddir)/type \
- -I $(top_builddir)/string/includes
-
-pkglib_LTLIBRARIES = libString.la
-
-libString_la_SOURCES = $(HEAD) $(SRC)
-
-SRC = sstrings.c \
- dstrings.c \
- cstrings.c \
- zstrings.c \
- sstringa.c \
- dstringa.c \
- cstringa.c \
- zstringa.c
-
-HEAD = ../includes/string.h
-
-####
-# Checking Part
-####
-
-check_INCLUDES = -I $(top_builddir)/string/includes \
- -I $(top_builddir)/type
-
-check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
- $(top_builddir)/type/libFloatComplex.la \
- $(top_builddir)/string/string/libString.la
-
-check_PROGRAMS = testString
-
-TESTS = testString
-
-#
-# -*- Dispine Tests -*-
-#
-testString_SOURCES = testString.c
-testString_CFLAGS = $(check_INCLUDES)
-testString_LDADD = $(check_LDADD)
-