summaryrefslogtreecommitdiff
path: root/src/statisticsFunctions/sum/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/statisticsFunctions/sum/Makefile.am')
-rw-r--r--src/statisticsFunctions/sum/Makefile.am65
1 files changed, 0 insertions, 65 deletions
diff --git a/src/statisticsFunctions/sum/Makefile.am b/src/statisticsFunctions/sum/Makefile.am
deleted file mode 100644
index a0f039d3..00000000
--- a/src/statisticsFunctions/sum/Makefile.am
+++ /dev/null
@@ -1,65 +0,0 @@
-##
-## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
-## Copyright (C) 2006-2008 - INRIA - Bruno JOFRET
-##
-## This file must be used under the terms of the CeCILL.
-## This source file is licensed as described in the file COPYING, which
-## you should have received as part of this distribution. The terms
-## are also available at
-## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
-##
-##
-
-libSum_la_CFLAGS = -I $(top_builddir)/type \
- -I $(top_builddir)/operations/includes \
- -I ../includes
-
-instdir = $(top_builddir)/lib
-
-pkglib_LTLIBRARIES = libSum.la
-
-libSum_la_SOURCES = $(HEAD) $(SRC)
-
-SRC = ssuma.c \
- srowsuma.c \
- scolumnsuma.c \
- dsuma.c \
- drowsuma.c \
- dcolumnsuma.c \
- csuma.c \
- crowsuma.c \
- ccolumnsuma.c \
- zsuma.c \
- zrowsuma.c \
- zcolumnsuma.c
-
-HEAD = ../includes/sum.h
-
-####
-# Checking Part
-####
-
-check_INCLUDES = -I $(top_builddir)/statisticsFunctions/includes \
- -I $(top_builddir)/operations/includes \
- -I $(top_builddir)/type
-
-check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
- $(top_builddir)/type/libFloatComplex.la \
- $(top_builddir)/operations/addition/libAddition.la \
- $(top_builddir)/statisticsFunctions/sum/libSum.la \
- @LIBMATH@
-
-check_PROGRAMS = testFloatSum testDoubleSum
-
-TESTS = testFloatSum testDoubleSum
-
-#
-# -*- Sum Tests -*-
-#
-testFloatSum_SOURCES = testFloatSum.c
-testFloatSum_CFLAGS = $(check_INCLUDES)
-testFloatSum_LDADD = $(check_LDADD)
-
-testDoubleSum_SOURCES =testDoubleSum.c
-testDoubleSum_CFLAGS = $(check_INCLUDES)
-testDoubleSum_LDADD = $(check_LDADD) \ No newline at end of file