summaryrefslogtreecommitdiff
path: root/src/matrixOperations/division/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/matrixOperations/division/Makefile.am')
-rw-r--r--src/matrixOperations/division/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/matrixOperations/division/Makefile.am b/src/matrixOperations/division/Makefile.am
index 26557166..1f03ba06 100644
--- a/src/matrixOperations/division/Makefile.am
+++ b/src/matrixOperations/division/Makefile.am
@@ -20,13 +20,17 @@ pkglib_LTLIBRARIES = libMatrixDivision.la
HEAD = ../includes/matrixDivision.h
libMatrixDivision_la_SOURCES = $(HEAD) \
- matrixDivision.c
+ sdiva.c \
+ ddiva.c
check_PROGRAMS = testMatrixDivision
check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
$(top_builddir)/type/libFloatComplex.la \
$(top_builddir)/lib/blas/libsciblas.la \
+ $(top_builddir)/lib/lapack/libscilapack.la \
+ $(top_builddir)/matrixOperations/transpose/libMatrixTranspose.la \
+ $(top_builddir)/matrixOperations/cat/libMatrixConcatenation.la \
libMatrixDivision.la
check_INCLUDES = -I $(top_builddir)/type \
@@ -36,4 +40,4 @@ testMatrixDivision_SOURCES = testMatrixDivision.c
testMatrixDivision_LDADD = $(check_LDADD)
testMatrixDivision_CFLAGS = $(check_INCLUDES)
-TESTS = testMatrixDivision \ No newline at end of file
+TESTS = testMatrixDivision