summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/tanh/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/elementaryFunctions/tanh/Makefile.am')
-rw-r--r--src/elementaryFunctions/tanh/Makefile.am25
1 files changed, 24 insertions, 1 deletions
diff --git a/src/elementaryFunctions/tanh/Makefile.am b/src/elementaryFunctions/tanh/Makefile.am
index c6ebda7e..a38e2914 100644
--- a/src/elementaryFunctions/tanh/Makefile.am
+++ b/src/elementaryFunctions/tanh/Makefile.am
@@ -5,7 +5,7 @@
## Made by Bruno JOFRET <bruno.jofret@inria.fr>
##
## Started on Fri Jan 5 10:19:16 2007 jofret
-## Last update Sun Mar 25 20:56:56 2007 bruno
+## Last update Wed Apr 18 16:53:46 2007 jofret
##
## Copyright INRIA 2007
##
@@ -31,3 +31,26 @@ SRC = stanhs.c \
ztanha.c
HEAD = ../includes/tanh.h
+
+####
+# Checking Part
+####
+
+check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
+ -I $(top_builddir)/type
+
+check_PROGRAMS = testTanh
+
+TESTS = testTanh
+
+#
+# -*- Hyperbolic Tangeant Tests -*-
+#
+testTanh_SOURCES = testTanh.c
+testTanh_CFLAGS = $(check_INCLUDES)
+testTanh_LDADD = $(top_builddir)/lib/libDoubleComplex.a \
+ $(top_builddir)/lib/libFloatComplex.a \
+ $(top_builddir)/lib/libTanh.a \
+ @LIBMATH@
+
+