summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/tan/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/elementaryFunctions/tan/Makefile.am')
-rw-r--r--src/elementaryFunctions/tan/Makefile.am23
1 files changed, 22 insertions, 1 deletions
diff --git a/src/elementaryFunctions/tan/Makefile.am b/src/elementaryFunctions/tan/Makefile.am
index d52d3956..b48157b3 100644
--- a/src/elementaryFunctions/tan/Makefile.am
+++ b/src/elementaryFunctions/tan/Makefile.am
@@ -5,7 +5,7 @@
## Made by Bruno JOFRET <bruno.jofret@inria.fr>
##
## Started on Fri Jan 5 10:19:16 2007 jofret
-## Last update Sun Mar 25 20:56:35 2007 bruno
+## Last update Wed Apr 18 16:51:17 2007 jofret
##
## Copyright INRIA 2007
##
@@ -31,3 +31,24 @@ SRC = stans.c \
ztana.c
HEAD = ../includes/tan.h
+
+####
+# Checking Part
+####
+
+check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
+ -I $(top_builddir)/type
+
+check_PROGRAMS = testTan
+
+TESTS = testTan
+
+#
+# -*- Tangeant Tests -*-
+#
+testTan_SOURCES = testTan.c
+testTan_CFLAGS = $(check_INCLUDES)
+testTan_LDADD = $(top_builddir)/lib/libDoubleComplex.a \
+ $(top_builddir)/lib/libFloatComplex.a \
+ $(top_builddir)/lib/libTan.a \
+ @LIBMATH@