summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/cos/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/elementaryFunctions/cos/Makefile.am')
-rw-r--r--src/elementaryFunctions/cos/Makefile.am16
1 files changed, 9 insertions, 7 deletions
diff --git a/src/elementaryFunctions/cos/Makefile.am b/src/elementaryFunctions/cos/Makefile.am
index afb30435..53690bef 100644
--- a/src/elementaryFunctions/cos/Makefile.am
+++ b/src/elementaryFunctions/cos/Makefile.am
@@ -10,14 +10,18 @@
##
##
-libCos_la_CFLAGS = -I ../../type \
- -I ../includes
+
+
+libCos_la_CFLAGS = -I $(top_builddir)/type \
+ -I $(top_builddir)/elementaryFunctions/includes
instdir = $(top_builddir)/lib
pkglib_LTLIBRARIES = libCos.la
-libCos_la_SOURCES = $(HEAD) $(SRC)
+libCos_la_SOURCES = $(HEAD) $(SRC)
+
+HEAD = ../includes/cos.h
SRC = scoss.c \
dcoss.c \
@@ -28,8 +32,6 @@ SRC = scoss.c \
ccosa.c \
zcosa.c
-HEAD = ../includes/cos.h
-
####
# Checking Part
####
@@ -57,10 +59,10 @@ TESTS = testFloatCos testDoubleCos
#
# -*- Cosine Tests -*-
#
-testFloatCos_SOURCES = testFloatCos.c
+testFloatCos_SOURCES = ../../includes/constant.h testCos.h testFloatCos.c
testFloatCos_CFLAGS = $(check_INCLUDES)
testFloatCos_LDADD = $(check_LDADD)
-testDoubleCos_SOURCES = testDoubleCos.c
+testDoubleCos_SOURCES = ../../includes/constant.h testCos.h testDoubleCos.c
testDoubleCos_CFLAGS = $(check_INCLUDES)
testDoubleCos_LDADD = $(check_LDADD) \ No newline at end of file