summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/atan/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/elementaryFunctions/atan/Makefile.am')
-rw-r--r--src/elementaryFunctions/atan/Makefile.am67
1 files changed, 0 insertions, 67 deletions
diff --git a/src/elementaryFunctions/atan/Makefile.am b/src/elementaryFunctions/atan/Makefile.am
deleted file mode 100644
index 2e4abca1..00000000
--- a/src/elementaryFunctions/atan/Makefile.am
+++ /dev/null
@@ -1,67 +0,0 @@
-##
-## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
-## Copyright (C) 2007-2008 - INRIA - Bruno JOFRET
-##
-## This file must be used under the terms of the CeCILL.
-## This source file is licensed as described in the file COPYING, which
-## you should have received as part of this distribution. The terms
-## are also available at
-## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
-##
-##
-
-libAtan_la_CFLAGS = -I $(top_builddir)/type \
- -I $(top_builddir)/elementaryFunctions/includes \
- -I $(top_builddir)/auxiliaryFunctions/includes
-
-
-instdir = $(top_builddir)/lib
-
-pkglib_LTLIBRARIES = libAtan.la
-
-libAtan_la_SOURCES = $(HEAD) $(SRC)
-
-SRC = satans.c \
- datans.c \
- catans.c \
- zatans.c \
- satana.c \
- datana.c \
- catana.c \
- zatana.c
-
-HEAD = ../includes/atan.h
-
-####
-# Checking Part
-####
-
-check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
- -I $(top_builddir)/type
-
-check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
- $(top_builddir)/type/libFloatComplex.la \
- $(top_builddir)/operations/addition/libAddition.la \
- $(top_builddir)/lib/lapack/libscilapack.la \
- $(top_builddir)/elementaryFunctions/sqrt/libSqrt.la \
- $(top_builddir)/elementaryFunctions/atan/libAtan.la \
- $(top_builddir)/elementaryFunctions/lnp1m1/libLnp1m1.la \
- $(top_builddir)/auxiliaryFunctions/abs/libAbs.la \
- $(top_builddir)/auxiliaryFunctions/pythag/libPythag.la \
- $(top_builddir)/operations/multiplication/libMultiplication.la \
- @LIBMATH@
-
-check_PROGRAMS = testFloatAtan testDoubleAtan
-
-TESTS = testFloatAtan testDoubleAtan
-
-#
-# -*- Arc tangeant Tests -*-
-#
-testFloatAtan_SOURCES = testAtan.h testFloatAtan.c
-testFloatAtan_CFLAGS = $(check_INCLUDES)
-testFloatAtan_LDADD = $(check_LDADD)
-
-testDoubleAtan_SOURCES = testAtan.h testDoubleAtan.c
-testDoubleAtan_CFLAGS = $(check_INCLUDES)
-testDoubleAtan_LDADD = $(check_LDADD)