summaryrefslogtreecommitdiff
path: root/src/auxiliaryFunctions/isempty/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/auxiliaryFunctions/isempty/Makefile.am')
-rw-r--r--src/auxiliaryFunctions/isempty/Makefile.am32
1 files changed, 15 insertions, 17 deletions
diff --git a/src/auxiliaryFunctions/isempty/Makefile.am b/src/auxiliaryFunctions/isempty/Makefile.am
index 0348ee2c..b34a3450 100644
--- a/src/auxiliaryFunctions/isempty/Makefile.am
+++ b/src/auxiliaryFunctions/isempty/Makefile.am
@@ -1,25 +1,23 @@
##
-## -*- makefile -*-
+## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
+## Copyright (C) 2008-2008 - INRIA - Bruno JOFRET
##
-## Makefile
-## Made by Bruno JOFRET <bruno.jofret@inria.fr>
+## This file must be used under the terms of the CeCILL.
+## This source file is licensed as described in the file COPYING, which
+## you should have received as part of this distribution. The terms
+## are also available at
+## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
##
-## Started on Fri Jan 5 10:19:16 2007 jofret
-## Last update Thu Apr 26 11:10:23 2007 jofret
-##
-## Copyright INRIA 2007
##
-AM_CFLAGS = -I ../../type \
- -I ../includes
+libIsempty_la_CFLAGS = -I ../../type \
+ -I ../includes
instdir = $(top_builddir)/lib
-inst_LIBRARIES = libIsempty.a
-
-noinst_LIBRARIES = libIsempty.a
+pkglib_LTLIBRARIES = libIsempty.la
-libIsempty_a_SOURCES = $(HEAD) $(SRC)
+libIsempty_la_SOURCES = $(HEAD) $(SRC)
SRC = sisemptya.c \
disemptya.c \
@@ -44,8 +42,8 @@ TESTS = testIsEmpty
#
testIsEmpty_SOURCES = testIsEmpty.c
testIsEmpty_CFLAGS = $(check_INCLUDES)
-testIsEmpty_LDADD = $(top_builddir)/lib/libDoubleComplex.a \
- $(top_builddir)/lib/libFloatComplex.a \
- $(top_builddir)/lib/libIsempty.a \
- $(top_builddir)/lib/libFind.a \
+testIsEmpty_LDADD = $(top_builddir)/type/libDoubleComplex.la \
+ $(top_builddir)/type/libFloatComplex.la \
+ $(top_builddir)/auxiliaryFunctions/isempty/libIsempty.la \
+ $(top_builddir)/auxiliaryFunctions/find/libFind.la \
@LIBMATH@