summaryrefslogtreecommitdiff
path: root/src/elementaryFunctions/sin/Makefile.am
diff options
context:
space:
mode:
authorjofret2009-04-28 06:53:00 +0000
committerjofret2009-04-28 06:53:00 +0000
commitb56c1d5508edf80f36c9a48e8806641f5cdf2cd8 (patch)
tree921ff5c8b47befe9b797cffa57bea9c940a7224c /src/elementaryFunctions/sin/Makefile.am
parent127ac18608c72acfed9d59599252ad62cb562ee5 (diff)
downloadscilab2c-b56c1d5508edf80f36c9a48e8806641f5cdf2cd8.tar.gz
scilab2c-b56c1d5508edf80f36c9a48e8806641f5cdf2cd8.tar.bz2
scilab2c-b56c1d5508edf80f36c9a48e8806641f5cdf2cd8.zip
Moving source code
Diffstat (limited to 'src/elementaryFunctions/sin/Makefile.am')
-rw-r--r--src/elementaryFunctions/sin/Makefile.am68
1 files changed, 0 insertions, 68 deletions
diff --git a/src/elementaryFunctions/sin/Makefile.am b/src/elementaryFunctions/sin/Makefile.am
deleted file mode 100644
index 967c7c23..00000000
--- a/src/elementaryFunctions/sin/Makefile.am
+++ /dev/null
@@ -1,68 +0,0 @@
-##
-## Scilab ( http://www.scilab.org/ ) - This file is part of Scilab
-## Copyright (C) 2006-2008 - INRIA - Bruno JOFRET
-##
-## This file must be used under the terms of the CeCILL.
-## This source file is licensed as described in the file COPYING, which
-## you should have received as part of this distribution. The terms
-## are also available at
-## http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
-##
-##
-
-libSin_la_CFLAGS = -I ../../type \
- -I ../includes
-
-instdir = $(top_builddir)/lib
-
-pkglib_LTLIBRARIES = libSin.la
-
-libSin_la_SOURCES = $(HEAD) $(SRC)
-
-SRC = ssins.c \
- dsins.c \
- csins.c \
- zsins.c \
- ssina.c \
- dsina.c \
- csina.c \
- zsina.c
-
-HEAD = ../includes/sin.h
-
-####
-# Checking Part
-####
-
-check_INCLUDES = -I $(top_builddir)/elementaryFunctions/includes \
- -I $(top_builddir)/type
-
-check_LDADD = $(top_builddir)/type/libDoubleComplex.la \
- $(top_builddir)/type/libFloatComplex.la \
- $(top_builddir)/operations/addition/libAddition.la \
- $(top_builddir)/lib/lapack/libscilapack.la \
- $(top_builddir)/elementaryFunctions/sin/libSin.la \
- $(top_builddir)/elementaryFunctions/cos/libCos.la \
- $(top_builddir)/elementaryFunctions/sinh/libSinh.la \
- $(top_builddir)/elementaryFunctions/exp/libExp.la \
- $(top_builddir)/elementaryFunctions/cosh/libCosh.la \
- $(top_builddir)/elementaryFunctions/sqrt/libSqrt.la \
- $(top_builddir)/auxiliaryFunctions/abs/libAbs.la \
- $(top_builddir)/auxiliaryFunctions/pythag/libPythag.la \
- $(top_builddir)/operations/multiplication/libMultiplication.la \
- @LIBMATH@
-
-check_PROGRAMS = testFloatSin testDoubleSin
-
-TESTS = testFloatSin testDoubleSin
-
-#
-# -*- Sine Tests -*-
-#
-testFloatSin_SOURCES = testSin.h testFloatSin.c
-testFloatSin_CFLAGS = $(check_INCLUDES)
-testFloatSin_LDADD = $(check_LDADD)
-
-testDoubleSin_SOURCES = testSin.h testDoubleSin.c
-testDoubleSin_CFLAGS = $(check_INCLUDES)
-testDoubleSin_LDADD = $(check_LDADD)