summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fa15891..cfbea10 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -105,8 +105,14 @@ add_subdirectory(tests)
set(CMAKE_SOURCE_DIR ${GRAS_SOURCE_DIR}/gnuradio)
set(CMAKE_BINARY_DIR ${GRAS_BINARY_DIR}/gnuradio)
+#Theron isnt affected by boost thread issues.
+#So we allow the gr black listed versions.
+OPTION(ENABLE_BAD_BOOST "Enable known bad versions of Boost" ON)
+
set(CMAKE_PROJECT_NAME gnuradio) #for submodule vars
+set(GR_MOAR_LIBRARIES ${GRAS_LIBRARIES})
+
add_subdirectory(gnuradio)
########################################################################