summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 6 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index e8e1394..87ae184 100644
--- a/setup.py
+++ b/setup.py
@@ -14,16 +14,17 @@ def get_version():
exec(compile(open(fname).read(), fname, 'exec'), data)
return data.get('__version__')
+
install_requires = [
- 'django==1.10',
- 'django-taggit==0.18.1',
- 'pytz==2016.4',
+ 'django==3.0.3',
+ 'django-taggit==1.2.0',
+ 'pytz==2019.3',
+ 'requests-oauthlib>=0.6.1',
'python-social-auth==0.2.19',
'tornado',
'psutil',
'ruamel.yaml==0.15.23',
'invoke==0.21.0',
- 'six',
'requests',
'markdown==2.6.9',
]
@@ -39,7 +40,7 @@ setup(
license='BSD License',
entry_points={
'console_scripts': [
- 'yaksh = yaksh.scripts.cli:main',
+ 'yaksh = yaksh.code_server:main',
],
},
description='A django app to conduct online programming tests.',