summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorprathamesh2015-02-19 12:36:02 +0530
committerprathamesh2015-02-19 12:36:02 +0530
commite7e82959bb819e60ef5ab21f1950404d20e661a8 (patch)
tree1fd64709e32dcb1a21332ebb3045c8723ea8c4be /setup.py
parent962cee1705509bb595cda51d104ef1ef7cf0b4fd (diff)
parent663e9945eddeda6bfe37b5d64c1a08a85d222f3e (diff)
downloadonline_test-e7e82959bb819e60ef5ab21f1950404d20e661a8.tar.gz
online_test-e7e82959bb819e60ef5ab21f1950404d20e661a8.tar.bz2
online_test-e7e82959bb819e60ef5ab21f1950404d20e661a8.zip
Merge branch 'app_package' into redirect_result_view
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py49
1 files changed, 49 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..79efa76
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,49 @@
+import os
+from setuptools import setup, find_packages
+
+README = open(os.path.join(os.path.dirname(__file__), 'README.rst')).read()
+
+# allow setup.py to be run from any path
+os.chdir(os.path.normpath(os.path.join(os.path.abspath(__file__), os.pardir)))
+
+link = 'git+https://github.com/prathamesh920/\
+django-taggit-autocomplete-modified.git'
+
+setup(
+ name='django-exam',
+ author='python team at IIT Bombay',
+ author_email='python@fossee.in',
+ version='0.1',
+ packages=find_packages(),
+ include_package_data=True,
+ license='BSD License',
+ entry_points = {
+ 'console_scripts': [
+ 'code_server = testapp.exam.code_server:main',
+ ],
+ },
+ description='A django app to conduct online tests.',
+ long_description=README,
+ install_requires=[
+ 'django==1.6',
+ 'mysql-python==1.2.5',
+ 'django-taggit==0.12.2',
+ 'django-taggit-autocomplete-modified > 0.1.0b4',
+ ],
+ dependency_links=[link+'#egg=django_taggit_autocomplete_modified-0.2'],
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Web Environment',
+ 'Framework :: Django',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: Education',
+ 'Intended Audience :: End Users/Desktop',
+ 'License :: OSI Approved :: BSD License',
+ 'Natural Language :: English',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
+ ],
+)