summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPrabhu Ramachandran2017-01-31 23:24:26 +0530
committerPrabhu Ramachandran2017-01-31 23:24:26 +0530
commit47ac6a343e1c1b48129f922bbf8459da58afe391 (patch)
treea0308418965657f1bba54e26ecc5d3c1c6b95351 /setup.py
parenta64b9c30f2cd4554734bba16b0aad7647475000d (diff)
downloadonline_test-47ac6a343e1c1b48129f922bbf8459da58afe391.tar.gz
online_test-47ac6a343e1c1b48129f922bbf8459da58afe391.tar.bz2
online_test-47ac6a343e1c1b48129f922bbf8459da58afe391.zip
Remove forced dependency on mysql.
This does not seem necessary to test yaksh and run it with sqlite. Production deployment should really use a separate requirements file.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py15
1 files changed, 3 insertions, 12 deletions
diff --git a/setup.py b/setup.py
index 34a4a54..37ed948 100644
--- a/setup.py
+++ b/setup.py
@@ -1,27 +1,18 @@
import os
from setuptools import setup, find_packages
-import sys
README = open(os.path.join(os.path.dirname(__file__), 'README.md')).read()
# allow setup.py to be run from any path
os.chdir(os.path.normpath(os.path.join(os.path.abspath(__file__), os.pardir)))
-install_requires=[
+install_requires = [
'django==1.9.5',
'django-taggit==0.18.1',
'pytz==2016.4',
'python-social-auth==0.2.19',
'tornado',
]
-if sys.version_info[:2] == (2, 7):
- install_requires+=[
- 'mysql-python==1.2.5'
-]
-if sys.version_info[0] >= 3:
- install_requires+=[
- 'mysqlclient==1.3.9'
-]
setup(
name='yaksh',
@@ -30,9 +21,9 @@ setup(
version='0.1.3',
packages=find_packages(),
include_package_data=True,
- url = 'https://pypi.python.org/pypi/yaksh/',
+ url='https://pypi.python.org/pypi/yaksh/',
license='BSD License',
- entry_points = {
+ entry_points={
'console_scripts': [
'yaksh = yaksh.scripts.cli:main',
],