summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorprathamesh2014-08-05 14:01:09 +0530
committerprathamesh2014-08-05 14:01:09 +0530
commit1d0250d9ec728760186d123669a27ef0f85400cd (patch)
treefb6269a985fbfa7220299587d7825441e30c8be0 /setup.py
parentecc920b833ddd7e163213afc7390fd958991dcf2 (diff)
downloadonline_test-1d0250d9ec728760186d123669a27ef0f85400cd.tar.gz
online_test-1d0250d9ec728760186d123669a27ef0f85400cd.tar.bz2
online_test-1d0250d9ec728760186d123669a27ef0f85400cd.zip
Placed setup.py in the parent folder.
pip install [git repo], this command will automatically run this setup file.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py44
1 files changed, 44 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..b69cbbb
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,44 @@
+import os
+from setuptools import setup
+
+README = open(os.path.join(os.path.dirname(__file__), 'README.rst')).read()
+
+# allow setup.py to be run from any path
+os.chdir(os.path.normpath(os.path.join(os.path.abspath(__file__), os.pardir)))
+
+setup(
+ name='django-exam',
+ author='Prabhu Ramachandran',
+ author_email='prabhu.ramachandran@gmail.com',
+ version='0.1',
+ packages=['testapp.exam'],
+ include_package_data=True,
+ license='BSD License',
+ entry_points = {
+ 'console_scripts': [
+ 'code_server = exam.code_server:main',
+ ],
+ },
+ description='A django app to conduct online test.',
+ long_description=README,
+ install_requires=[
+ 'django',
+ 'django-taggit',
+ 'django-taggit-autocomplete-modified',
+ ],
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Web Environment',
+ 'Framework :: Django',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: Education',
+ 'Intended Audience :: End Users/Desktop',
+ 'License :: OSI Approved :: BSD License',
+ 'Natural Language :: English',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
+ ],
+)