summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorPrabhu Ramachandran2015-03-01 10:31:18 +0530
committerPrabhu Ramachandran2015-03-01 10:31:18 +0530
commit997a7907a13b394e5ca69fadf17f5bb4d5445536 (patch)
tree4950c79bca8c99f8f83e20d314d3845aeff87423 /setup.py
parent265ad4d17f481e30a84350e8eb96e72c8cedef6b (diff)
parent2c6aa7e1ec058453ce8c559fce26b3ee05d99cae (diff)
downloadonline_test-997a7907a13b394e5ca69fadf17f5bb4d5445536.tar.gz
online_test-997a7907a13b394e5ca69fadf17f5bb4d5445536.tar.bz2
online_test-997a7907a13b394e5ca69fadf17f5bb4d5445536.zip
Merge pull request #36 from prathamesh920/app_package
App package
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py49
1 files changed, 49 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..79efa76
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,49 @@
+import os
+from setuptools import setup, find_packages
+
+README = open(os.path.join(os.path.dirname(__file__), 'README.rst')).read()
+
+# allow setup.py to be run from any path
+os.chdir(os.path.normpath(os.path.join(os.path.abspath(__file__), os.pardir)))
+
+link = 'git+https://github.com/prathamesh920/\
+django-taggit-autocomplete-modified.git'
+
+setup(
+ name='django-exam',
+ author='python team at IIT Bombay',
+ author_email='python@fossee.in',
+ version='0.1',
+ packages=find_packages(),
+ include_package_data=True,
+ license='BSD License',
+ entry_points = {
+ 'console_scripts': [
+ 'code_server = testapp.exam.code_server:main',
+ ],
+ },
+ description='A django app to conduct online tests.',
+ long_description=README,
+ install_requires=[
+ 'django==1.6',
+ 'mysql-python==1.2.5',
+ 'django-taggit==0.12.2',
+ 'django-taggit-autocomplete-modified > 0.1.0b4',
+ ],
+ dependency_links=[link+'#egg=django_taggit_autocomplete_modified-0.2'],
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Web Environment',
+ 'Framework :: Django',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: Education',
+ 'Intended Audience :: End Users/Desktop',
+ 'License :: OSI Approved :: BSD License',
+ 'Natural Language :: English',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.6',
+ 'Programming Language :: Python :: 2.7',
+ 'Topic :: Internet :: WWW/HTTP :: Dynamic Content',
+ ],
+)