summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authormahesh2017-03-20 17:04:46 +0530
committermahesh2017-03-20 17:04:46 +0530
commitb5daabb45621ac47c98382303800cb7a240827c2 (patch)
treef3369879e3170a2a5e831fe6763a4615d27e2bec /setup.py
parentac292ed1099b49f9d0e8a7ed3699bacdd8031de3 (diff)
parent23ecd8fa33e7fa2e953aa9715ae45a2869a044a0 (diff)
downloadonline_test-b5daabb45621ac47c98382303800cb7a240827c2.tar.gz
online_test-b5daabb45621ac47c98382303800cb7a240827c2.tar.bz2
online_test-b5daabb45621ac47c98382303800cb7a240827c2.zip
Merge branch 'master' of https://github.com/fossee/online_test into fill_in_the_blanks
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 8 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 37ed948..c5dd77a 100644
--- a/setup.py
+++ b/setup.py
@@ -6,6 +6,13 @@ README = open(os.path.join(os.path.dirname(__file__), 'README.md')).read()
# allow setup.py to be run from any path
os.chdir(os.path.normpath(os.path.join(os.path.abspath(__file__), os.pardir)))
+def get_version():
+ import os
+ data = {}
+ fname = os.path.join('online_test', '__init__.py')
+ exec(compile(open(fname).read(), fname, 'exec'), data)
+ return data.get('__version__')
+
install_requires = [
'django==1.9.5',
'django-taggit==0.18.1',
@@ -18,7 +25,7 @@ setup(
name='yaksh',
author='Python Team at FOSSEE, IIT Bombay',
author_email='python@fossee.in',
- version='0.1.3',
+ version=get_version(),
packages=find_packages(),
include_package_data=True,
url='https://pypi.python.org/pypi/yaksh/',