summaryrefslogtreecommitdiff
path: root/Ubuntu/nghdl.spec
diff options
context:
space:
mode:
authorBladen Martin2020-08-06 19:16:04 +0530
committerGitHub2020-08-06 19:16:04 +0530
commitf6dab221722de039d70375a7692848f22c9be8a7 (patch)
tree455cfad11eac6d9a01e75924f54d31444c2e162e /Ubuntu/nghdl.spec
parent61fd2a0cec774a9076b1e45c53973a037d333147 (diff)
parent4e4d9e8285cbf9cedde362acf82ab79fdc5497d1 (diff)
downloadnghdl-f6dab221722de039d70375a7692848f22c9be8a7.tar.gz
nghdl-f6dab221722de039d70375a7692848f22c9be8a7.tar.bz2
nghdl-f6dab221722de039d70375a7692848f22c9be8a7.zip
Merge pull request #1 from rahulp13/installers
Installers
Diffstat (limited to 'Ubuntu/nghdl.spec')
-rw-r--r--Ubuntu/nghdl.spec32
1 files changed, 32 insertions, 0 deletions
diff --git a/Ubuntu/nghdl.spec b/Ubuntu/nghdl.spec
new file mode 100644
index 0000000..61f3fa8
--- /dev/null
+++ b/Ubuntu/nghdl.spec
@@ -0,0 +1,32 @@
+# -*- mode: python ; coding: utf-8 -*-
+
+block_cipher = None
+
+a = Analysis(['nghdl/src/ngspice_ghdl.py'],
+ pathex=['/home/rahul/Music'],
+ binaries=[],
+ datas=[],
+ hiddenimports=['PyQt4.sip'],
+ hookspath=[],
+ runtime_hooks=[],
+ excludes=[],
+ win_no_prefer_redirects=False,
+ win_private_assemblies=False,
+ cipher=block_cipher,
+ noarchive=False)
+pyz = PYZ(a.pure, a.zipped_data,
+ cipher=block_cipher)
+exe = EXE(pyz,
+ a.scripts,
+ a.binaries,
+ a.zipfiles,
+ a.datas,
+ [],
+ name='nghdl',
+ debug=False,
+ bootloader_ignore_signals=False,
+ strip=False,
+ upx=True,
+ upx_exclude=[],
+ runtime_tmpdir=None,
+ console=True )