summaryrefslogtreecommitdiff
path: root/volk/orc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'volk/orc/Makefile.am')
-rw-r--r--volk/orc/Makefile.am52
1 files changed, 52 insertions, 0 deletions
diff --git a/volk/orc/Makefile.am b/volk/orc/Makefile.am
new file mode 100644
index 000000000..a469638c1
--- /dev/null
+++ b/volk/orc/Makefile.am
@@ -0,0 +1,52 @@
+#
+# Copyright 2008 Free Software Foundation, Inc.
+#
+# This file is part of GNU Radio
+#
+# GNU Radio is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GNU Radio is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+#
+
+AM_CPPFLAGS = $(STD_DEFINES_AND_INCLUDES) $(ORC_CFLAGS)
+
+include $(top_srcdir)/Makefile.common
+lib_LTLIBRARIES = libvolk_orc.la
+libvolk_orc_la_LDFLAGS = $(ORC_LDFLAGS)
+
+libvolk_orc_la_SOURCES = \
+volk_8s_convert_16s_aligned16_orc_impl.orc \
+volk_8s_convert_32f_aligned16_orc_impl.orc \
+volk_16u_byteswap_aligned16_orc_impl.orc \
+volk_32s_and_aligned16_orc_impl.orc \
+volk_32s_or_aligned16_orc_impl.orc \
+volk_32f_add_aligned16_orc_impl.orc \
+volk_32f_subtract_aligned16_orc_impl.orc \
+volk_32f_divide_aligned16_orc_impl.orc \
+volk_32f_multiply_aligned16_orc_impl.orc \
+volk_32f_sqrt_aligned16_orc_impl.orc \
+volk_32f_max_aligned16_orc_impl.orc \
+volk_32f_min_aligned16_orc_impl.orc \
+volk_32fc_magnitude_32f_aligned16_orc_impl.orc \
+volk_32fc_magnitude_16s_aligned16_orc_impl.orc \
+volk_16sc_magnitude_16s_aligned16_orc_impl.orc \
+volk_16sc_deinterleave_16s_aligned16_orc_impl.orc \
+volk_16sc_deinterleave_32f_aligned16_orc_impl.orc \
+volk_16sc_deinterleave_real_8s_aligned16_orc_impl.orc
+
+
+
+my_ORCC_FLAGS = --implementation $(ORCC_FLAGS)
+
+.orc.c:
+ $(ORCC) $(my_ORCC_FLAGS) -o $@ $<