summaryrefslogtreecommitdiff
path: root/volk/lib/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'volk/lib/Makefile.am')
-rw-r--r--volk/lib/Makefile.am80
1 files changed, 13 insertions, 67 deletions
diff --git a/volk/lib/Makefile.am b/volk/lib/Makefile.am
index f609f5bf9..63df85244 100644
--- a/volk/lib/Makefile.am
+++ b/volk/lib/Makefile.am
@@ -1,5 +1,5 @@
#
-# Copyright 2010 Free Software Foundation, Inc.
+# Copyright 2010,2011 Free Software Foundation, Inc.
#
# This file is part of GNU Radio
#
@@ -63,76 +63,17 @@ EXTRA_DIST = \
# The main library
# ----------------------------------------------------------------
-universal_runtime_CODE = \
- volk_runtime.c \
- volk_init.c \
+libvolk_runtime_la_SOURCES = \
+ $(platform_CODE) \
+ volk_runtime.c \
+ volk_init.c \
volk_rank_archs.c
-universal_CODE = \
+libvolk_la_SOURCES = \
+ $(platform_CODE) \
volk.c \
volk_environment_init.c
-generic_CODE = \
- volk_cpu_generic.c
-
-x86_CODE = \
- volk_cpu_x86.c
-
-x86_SUBCODE = \
- cpuid_x86.S
-
-x86_64_SUBCODE = \
- cpuid_x86_64.S
-
-powerpc_CODE = \
- volk_cpu_powerpc.c
-
-
-if MD_CPU_generic
-libvolk_la_SOURCES = \
- $(generic_CODE) \
- $(universal_CODE)
-libvolk_runtime_la_SOURCES = \
- $(generic_CODE) \
- $(universal_runtime_CODE)
-
-endif
-
-if MD_CPU_x86
-if MD_SUBCPU_x86_64
-libvolk_la_SOURCES = \
- $(x86_CODE) \
- $(x86_64_SUBCODE) \
- $(universal_CODE)
-
-libvolk_runtime_la_SOURCES = \
- $(x86_CODE) \
- $(x86_64_SUBCODE) \
- $(universal_runtime_CODE)
-else
-libvolk_la_SOURCES = \
- $(x86_CODE) \
- $(x86_SUBCODE) \
- $(universal_CODE)
-
-libvolk_runtime_la_SOURCES = \
- $(x86_CODE) \
- $(x86_SUBCODE) \
- $(universal_runtime_CODE)
-endif
-endif
-
-
-if MD_CPU_powerpc
-libvolk_la_SOURCES = \
- $(powerpc_CODE) \
- $(universal_CODE)
-
-libvolk_runtime_la_SOURCES = \
- $(powerpc_CODE) \
- $(universal_runtime_CODE)
-endif
-
volk_orc_LDFLAGS = \
$(ORC_LDFLAGS) \
-lorc-0.4
@@ -182,11 +123,16 @@ noinst_PROGRAMS = \
testqa_SOURCES = testqa.cc qa_utils.cc
testqa_CPPFLAGS = -DBOOST_TEST_DYN_LINK -DBOOST_TEST_MAIN
testqa_LDFLAGS = -lboost_unit_test_framework
+if LV_HAVE_ORC
testqa_LDADD = \
libvolk.la \
libvolk_runtime.la \
../orc/libvolk_orc.la
-
+else
+testqa_LDADD = \
+ libvolk.la \
+ libvolk_runtime.la
+endif
distclean-local:
rm -f volk.c