summaryrefslogtreecommitdiff
path: root/volk/lib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'volk/lib/CMakeLists.txt')
-rw-r--r--volk/lib/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/volk/lib/CMakeLists.txt b/volk/lib/CMakeLists.txt
index b45f89d02..6e80e99e8 100644
--- a/volk/lib/CMakeLists.txt
+++ b/volk/lib/CMakeLists.txt
@@ -72,6 +72,18 @@ foreach(line ${arch_flag_lines})
endforeach(line)
########################################################################
+# implement overruling in the ORC case,
+# since ORC always passes flag detection
+########################################################################
+if(ORC_FOUND)
+ message(STATUS "Overruled arch not orc")
+ list(REMOVE_ITEM available_archs norc)
+else()
+ message(STATUS "Overruled arch orc")
+ list(REMOVE_ITEM available_archs orc)
+endif()
+
+########################################################################
# implement overruling in the non-multilib case
# this makes things work when both -m32 and -m64 pass
########################################################################